summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpjmattal <pjmattal>2005-02-23 06:31:39 +0100
committerpjmattal <pjmattal>2005-02-23 06:31:39 +0100
commit256f0ff0cf91e0c32cfbbbe64e2b9cd6f94f18d0 (patch)
tree4a7385f4a4e22ff2c0c2ae57c63f78f4f5679258
parenteb000511dac404faca0a9e81432a2a3395f50124 (diff)
downloadaur-256f0ff0cf91e0c32cfbbbe64e2b9cd6f94f18d0.tar.gz
aur-256f0ff0cf91e0c32cfbbbe64e2b9cd6f94f18d0.tar.xz
fixed minor bugs
-rw-r--r--LAUNCH.txt7
-rwxr-xr-xtupkg/update/tupkgupdate2
-rw-r--r--web/html/pkgsubmit.php2
3 files changed, 9 insertions, 2 deletions
diff --git a/LAUNCH.txt b/LAUNCH.txt
index f04a51dd..0b7ff35e 100644
--- a/LAUNCH.txt
+++ b/LAUNCH.txt
@@ -3,6 +3,8 @@ This is the list of things we need to get done by 2/15 in order to make a
TIER 1 (critical)
* a package should be made of tupkg client tool
+* tupkgupdate needs a way to find out what the repo is called; possibly a
+ file in the top level dir of the cvs repo called "NAME"?
TIER 2 (pretty important)
* tupkg and tupkgs should not output unhashed passwords
@@ -11,8 +13,13 @@ TIER 2 (pretty important)
* add foreign key constraints with on delete cascade to make sure
entries are not orphaned in PackageSources and PackageDepends
* migrate to InnoDB tables?
+* tupkgupdate should not run gensync if repo is empty (but should delete
+ db file if it exists)
TIER 3 (noncritical)
* tupkgupdate should use updatesync instead of gensync - Paul
* error message when a non TU tries to adopt packages
* add method from the web for setting/changing package category
+* tupkgupdate should have a flag to keep it from modifying the repo if
+ suddenly all the PKGBUILDs disappear from the CVS dir (probably an error
+ not actual clearing house)
diff --git a/tupkg/update/tupkgupdate b/tupkg/update/tupkgupdate
index b700177d..8fe31420 100755
--- a/tupkg/update/tupkgupdate
+++ b/tupkg/update/tupkgupdate
@@ -122,7 +122,7 @@ class PackageDatabase:
"VALUES (" + str(id) + ", '" + source + "')")
# PackageDepends
for dep in package.depends:
- depid = self.lookupOrDummy(dep, locationId)
+ depid = self.lookupOrDummy(dep)
q.execute("INSERT INTO PackageDepends (PackageID, DepPkgID) " +
"VALUES (" + str(id) + ", " + str(depid) + ")")
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index f6e699bf..f9e9c3c2 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -160,7 +160,7 @@ if ($_COOKIE["AURSID"]) {
}
$shcmd = "/bin/sh -c 'mv ".$upload_file." ".$INCOMING_DIR.$pkg_name;
- $shcmd.= "/".$_FILES["pfile"]["name"]."'");
+ $shcmd.= "/".$_FILES["pfile"]["name"]."'";
@exec($shcmd);
# if no error, get list of directory contents and process PKGBUILD