summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-03-17 15:36:43 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-03-17 15:37:03 +0100
commit1dffac4f0cca7bc2f6bdc044e2805edff5be1c87 (patch)
treeb16c0d9dd7afd1d4db3239632d6f5116a733ad47
parent4b3da4f08d06e1000aa2ab7fdeec96941d9ffd16 (diff)
downloadaur-packages-1dffac4f0cca7bc2f6bdc044e2805edff5be1c87.tar.gz
aur-packages-1dffac4f0cca7bc2f6bdc044e2805edff5be1c87.tar.xz
remove apache
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--apache/PKGBUILD86
-rw-r--r--apache/arch.layout22
-rwxr-xr-xapache/httpd65
-rw-r--r--apache/httpd.logrotate5
4 files changed, 0 insertions, 178 deletions
diff --git a/apache/PKGBUILD b/apache/PKGBUILD
deleted file mode 100644
index deca78e..0000000
--- a/apache/PKGBUILD
+++ /dev/null
@@ -1,86 +0,0 @@
-# $Id: PKGBUILD 67091 2010-02-03 01:02:51Z andrea $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Pierre Schmitz <pierre@archlinux.de>
-
-pkgname=apache
-pkgver=2.2.14
-pkgrel=2
-pkgdesc='A high performance Unix-based HTTP server'
-arch=('i686' 'x86_64')
-options=('!libtool')
-url='http://www.apache.org/dist/httpd'
-license=('APACHE')
-backup=(etc/httpd/conf/httpd.conf
- etc/httpd/conf/extra/httpd-{autoindex,dav,default,info,languages}.conf
- etc/httpd/conf/extra/httpd-{manual,mpm,multilang-errordoc}.conf
- etc/httpd/conf/extra/httpd-{ssl,userdir,vhosts}.conf
- etc/logrotate.d/httpd)
-depends=('openssl' 'zlib' 'apr-util' 'pcre')
-optdepends=('lynx: apachectl status')
-source=("http://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2"
- 'httpd.logrotate'
- 'httpd'
- 'arch.layout')
-md5sums=('a5226203aaf97e5b941c41a71c112704'
- 'f4d627c64024c1b7b95efb5ffbaa625e'
- '9e001fbb082a08113e7f4bc431085c11'
- '3d659d41276ba3bfcb20c231eb254e0c')
-
-build() {
- cd ${srcdir}/httpd-${pkgver}
-
- # set default user
- sed -e 's#User daemon#User http#' \
- -e 's#Group daemon#Group http#' \
- -i docs/conf/httpd.conf.in
-
- cat ${srcdir}/arch.layout >> config.layout
- ./configure --enable-layout=Arch \
- --enable-modules=all \
- --enable-mods-shared=all \
- --enable-so \
- --enable-suexec \
- --with-suexec-caller=http \
- --with-suexec-docroot=/srv/http \
- --with-suexec-logfile=/var/log/httpd/suexec.log \
- --with-suexec-bin=/usr/sbin/suexec \
- --with-suexec-uidmin=99 --with-suexec-gidmin=99 \
- --enable-ldap --enable-authnz-ldap \
- --enable-cache --enable-disk-cache --enable-mem-cache --enable-file-cache \
- --enable-ssl --with-ssl \
- --enable-deflate --enable-cgid \
- --enable-proxy --enable-proxy-connect \
- --enable-proxy-http --enable-proxy-ftp \
- --enable-dbd \
- --with-apr=/usr/bin/apr-1-config \
- --with-apr-util=/usr/bin/apu-1-config \
- --with-pcre=/usr \
- --with-mpm=worker
-
- make || return 1
-
- make DESTDIR=${pkgdir} install
- install -D -m755 ${srcdir}/httpd ${pkgdir}/etc/rc.d/httpd
- install -D -m644 ${srcdir}/httpd.logrotate ${pkgdir}/etc/logrotate.d/httpd
-
- # symlinks for /etc/httpd
- ln -fs /var/log/httpd ${pkgdir}/etc/httpd/logs
- ln -fs /var/run/httpd ${pkgdir}/etc/httpd/run
- ln -fs /usr/lib/httpd/modules ${pkgdir}/etc/httpd/modules
- ln -fs /usr/lib/httpd/build ${pkgdir}/etc/httpd/build
-
- # set sane defaults
- sed -e 's#/usr/lib/httpd/modules/#modules/#' \
- -e 's|#\(Include conf/extra/httpd-multilang-errordoc.conf\)|\1|' \
- -e 's|#\(Include conf/extra/httpd-autoindex.conf\)|\1|' \
- -e 's|#\(Include conf/extra/httpd-languages.conf\)|\1|' \
- -e 's|#\(Include conf/extra/httpd-userdir.conf\)|\1|' \
- -e 's|#\(Include conf/extra/httpd-default.conf\)|\1|' \
- -i ${pkgdir}/etc/httpd/conf/httpd.conf
-
- # cleanup
- rm -rf ${pkgdir}/usr/share/httpd/manual
- rm -rf ${pkgdir}/etc/httpd/conf/original
- rm -rf ${pkgdir}/srv/
- rm -rf ${pkgdir}/usr/bin
-}
diff --git a/apache/arch.layout b/apache/arch.layout
deleted file mode 100644
index ab59db8..0000000
--- a/apache/arch.layout
+++ /dev/null
@@ -1,22 +0,0 @@
-<Layout Arch>
- prefix: /etc/httpd
- exec_prefix: /usr
- bindir: /usr/bin
- sbindir: /usr/sbin
- libdir: /usr/lib/httpd
- libexecdir: /usr/lib/httpd/modules
- mandir: /usr/share/man
- sysconfdir: /etc/httpd/conf
- datadir: /usr/share/httpd
- installbuilddir: /usr/lib/httpd/build
- errordir: /usr/share/httpd/error
- iconsdir: /usr/share/httpd/icons
- htdocsdir: /srv/http
- manualdir: /usr/share/httpd/manual
- cgidir: /srv/http/cgi-bin
- includedir: /usr/include/httpd
- localstatedir: /var
- runtimedir: /var/run/httpd
- logfiledir: /var/log/httpd
- proxycachedir: /var/cache/httpd
-</Layout> \ No newline at end of file
diff --git a/apache/httpd b/apache/httpd
deleted file mode 100755
index 65ccb6e..0000000
--- a/apache/httpd
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/bin/bash
-
-daemon_name=httpd
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-APACHECTL=/usr/sbin/apachectl
-
-case "$1" in
- start)
- stat_busy "Starting Apache Web Server"
- [ ! -d /var/run/httpd ] && install -d /var/run/httpd
- if $APACHECTL start &>/dev/null ; then
- add_daemon $daemon_name
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
-
- stop)
- stat_busy "Stopping Apache Web Server"
- if $APACHECTL stop &>/dev/null ; then
- rm_daemon $daemon_name
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
-
- reload)
- stat_busy "Reloading Apache Web Server"
- if $APACHECTL graceful &>/dev/null ; then
- add_daemon $daemon_name
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
-
- restart)
- stat_busy "Restarting Apache Web Server"
- if $APACHECTL restart &>/dev/null ; then
- add_daemon $daemon_name
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
-
- status)
- stat_busy "Checking Apache Web Server status";
- ck_status $daemon_name
- ;;
-
- *)
- echo "usage: $0 {start|stop|reload|restart|status}"
-esac
-
-exit 0
diff --git a/apache/httpd.logrotate b/apache/httpd.logrotate
deleted file mode 100644
index 3f9298c..0000000
--- a/apache/httpd.logrotate
+++ /dev/null
@@ -1,5 +0,0 @@
-/var/log/httpd/*log {
- postrotate
- /bin/kill -HUP `cat /var/run/httpd/httpd.pid 2>/dev/null` 2> /dev/null || true
- endscript
-}