summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-05-31 20:38:21 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-05-31 20:38:21 +0200
commit313df1cf5bf1a1c8491f919b068c35531e639496 (patch)
tree846075469960ae1a0af172dbe3d6cec00c41794f
parentb8c04f4a2143480b7e0667d031061c682635aa4d (diff)
downloadaur-packages-313df1cf5bf1a1c8491f919b068c35531e639496.tar.gz
aur-packages-313df1cf5bf1a1c8491f919b068c35531e639496.tar.xz
mtr-cli: add hacky no-gtk patch
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--mtr-cli/PKGBUILD11
-rw-r--r--mtr-cli/no_gtk.patch26
2 files changed, 32 insertions, 5 deletions
diff --git a/mtr-cli/PKGBUILD b/mtr-cli/PKGBUILD
index 5b378ab..2383be7 100644
--- a/mtr-cli/PKGBUILD
+++ b/mtr-cli/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=mtr-cli
pkgver=0.77
-pkgrel=1
+pkgrel=2
pkgdesc="Combines the functionality of traceroute and ping into one tool"
arch=('i686' 'x86_64')
license=('GPL')
depends=('ncurses>=5.7')
conflicts=('mtr')
-source=(ftp://ftp.bitwizard.nl/mtr/mtr-${pkgver}.tar.gz)
+source=(ftp://ftp.bitwizard.nl/mtr/mtr-${pkgver}.tar.gz no_gtk.patch)
url="http://www.bitwizard.nl/mtr/"
build() {
@@ -17,9 +17,10 @@ build() {
aclocal
autoconf
automake
- sh ./configure --prefix=/usr --disable-gtktest --without-gtk || return 1
+ sed -i 's#./configure#./configure --prefix=/usr --without-gtk#' Makefile
+ patch -p0 < "$srcdir/no_gtk.patch"
make || return 1
make DESTDIR="${pkgdir}" install || return 1
}
-md5sums=('a05e5f428118ce22cef06fb5a6c0ee34')
-sha1sums=('5b77abb40464ca92aa545afae4f3aaf1ad341999')
+md5sums=('a05e5f428118ce22cef06fb5a6c0ee34'
+ '6ac91ddba465f3bf5d2af26b533b578f')
diff --git a/mtr-cli/no_gtk.patch b/mtr-cli/no_gtk.patch
new file mode 100644
index 0000000..2fae6c2
--- /dev/null
+++ b/mtr-cli/no_gtk.patch
@@ -0,0 +1,26 @@
+--- configure_2010-05-31_203051 2010-05-31 20:30:51.000000000 +0200
++++ configure 2010-05-31 20:36:32.000000000 +0200
+@@ -4711,14 +4711,15 @@
+
+
+ if test "x$WANTS_GTK" = "xyes"; then
+- AM_PATH_GTK_2_0(2.6.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
+- LIBS="$LIBS $GTK_LIBS -lm",
+- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Building without GTK2 display support" >&5
+-$as_echo "$as_me: WARNING: Building without GTK2 display support" >&2;}
+-
+-$as_echo "#define NO_GTK 1" >>confdefs.h
+-
+- GTK_OBJ="")
++ true
++# AM_PATH_GTK_2_0(2.6.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
++# LIBS="$LIBS $GTK_LIBS -lm",
++# { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Building without GTK2 display support" >&5
++#$as_echo "$as_me: WARNING: Building without GTK2 display support" >&2;}
++#
++#$as_echo "#define NO_GTK 1" >>confdefs.h
++#
++# GTK_OBJ="")
+ else
+ $as_echo "#define NO_GTK 1" >>confdefs.h
+