summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2012-08-18 15:40:21 +0200
committerFlorian Pritz <bluewind@xinu.at>2012-08-18 15:40:21 +0200
commit387564daaae46166eacd9dce37bbcaff4ad09ab6 (patch)
tree9b24be7c39c19368086dd972fcac619529042ddd
parentb6847ef7e6f28d2832d4bc8ca12b764083f20d7d (diff)
downloadaur-packages-387564daaae46166eacd9dce37bbcaff4ad09ab6.tar.gz
aur-packages-387564daaae46166eacd9dce37bbcaff4ad09ab6.tar.xz
spampd: add systemd service file
Signed-off-by: Florian Pritz <bluewind@xinu.at>
-rw-r--r--spampd/PKGBUILD8
-rw-r--r--spampd/spampd.service9
2 files changed, 14 insertions, 3 deletions
diff --git a/spampd/PKGBUILD b/spampd/PKGBUILD
index f13015c..008c59d 100644
--- a/spampd/PKGBUILD
+++ b/spampd/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Florian "Bluewind" Pritz <flo@xssn.at>
pkgname=spampd
pkgver=2.30
-pkgrel=4
+pkgrel=5
pkgdesc="Spamassassin Proxy Daemon"
arch=('any')
url="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
@@ -10,10 +10,11 @@ depends=('perl' 'perl-net-server' 'spamassassin')
backup=(etc/conf.d/spampd)
install=spampd.install
source=("http://www.worlddesign.com/Content/rd/mta/$pkgname/$pkgname-$pkgver.tar.gz"
- rc-script rc-config)
+ rc-script rc-config spampd.service)
md5sums=('742c6f2cb75db54e59d044a8ee40445f'
'da17b3904a63252931cfb5f02e6a089f'
- 'f452cf5046abc218bffb1e951485d8f0')
+ 'f452cf5046abc218bffb1e951485d8f0'
+ '0ee1229042bf795a22711d6fe819fda0')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -28,6 +29,7 @@ package() {
install -Dm755 "$srcdir/rc-script" "$pkgdir/etc/rc.d/spampd"
install -Dm644 "$srcdir/rc-config" "$pkgdir/etc/conf.d/spampd"
install -Dm644 spampd.8.gz "$pkgdir/usr/share/man/man8/spampd.8.gz"
+ install -Dm644 spampd.service "$pkgdir/usr/lib/systemd/system/spampd.service"
}
# vim:set ts=2 sw=2 et:
diff --git a/spampd/spampd.service b/spampd/spampd.service
new file mode 100644
index 0000000..514c3c7
--- /dev/null
+++ b/spampd/spampd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Spamassassin Proxy Daemon
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/spampd --port=10025 --relayhost=127.0.0.1:10026 --tagall --log-rules-hit --user spampd --group spampd --pid=/home/spampd/spampd.pid --nodetach
+
+[Install]
+WantedBy=multi-user.target