summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-07-13 09:05:18 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-07-13 09:05:18 +0200
commit953368befe24437af41c0309263040ec6ce5d25d (patch)
tree5f9275898d8fa8d88ae43d0e696b5c7c20d56244
parent8d23351755ef023dc68e90de539ae086dda7dcec (diff)
downloadaur-packages-953368befe24437af41c0309263040ec6ce5d25d.tar.gz
aur-packages-953368befe24437af41c0309263040ec6ce5d25d.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
-rw-r--r--apcupsd-cli/PKGBUILD36
-rwxr-xr-xapcupsd-cli/apcupsd44
-rw-r--r--arno-iptables-firewall/PKGBUILD40
-rw-r--r--arno-iptables-firewall/arno-iptables-firewall.patch7
-rw-r--r--perl-universal-require/PKGBUILD23
-rw-r--r--radvd/PKGBUILD39
-rw-r--r--radvd/radvd.install57
-rw-r--r--radvd/radvd.rc.d37
-rw-r--r--rtorrent-color/PKGBUILD28
-rw-r--r--rtorrent-color/rtorrent-0.8.4-SVN-canvas-fix.patch.part0
-rw-r--r--rtorrent-color/rtorrent-0.8.5.tar.gz.part0
-rw-r--r--rtorrent-color/rtorrent-0.8.6-canvas-fix.patch321
-rw-r--r--rtorrent-color/rtorrent-color.install11
-rw-r--r--rtorrent-extended/PKGBUILD2
14 files changed, 617 insertions, 28 deletions
diff --git a/apcupsd-cli/PKGBUILD b/apcupsd-cli/PKGBUILD
new file mode 100644
index 0000000..ba47f08
--- /dev/null
+++ b/apcupsd-cli/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 8842 2010-01-21 22:55:25Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Todd Musall <tmusall@comcast.net>
+
+pkgname=apcupsd-cli
+_orig=apcupsd
+pkgver=3.14.8
+pkgrel=1
+pkgdesc="Apcupsd version without GUI and webinterface"
+arch=(i686 x86_64)
+url="http://www.apcupsd.org"
+license=('GPL')
+depends=('gcc-libs')
+makedepends=('pkgconfig')
+conflicts=('apcupsd')
+backup=(etc/apcupsd/apcupsd.conf etc/apcupsd/hosts.conf \
+ etc/apcupsd/multimon.conf)
+source=(http://downloads.sourceforge.net/apcupsd/$_orig-$pkgver.tar.gz \
+ apcupsd)
+md5sums=('cd17f0a903dc2220e55ed54e242359d2'
+ '5eae3c4d921eeb81798a0250fe3dd111')
+
+build() {
+ cd $startdir/src/$_orig-$pkgver
+ ./configure --prefix=/usr --libexecdir=/usr/lib/$_orig \
+ --enable-usb --enable-net \
+ --with-upstype=usb --with-upscable=usb \
+ --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+ --enable-pthreads
+
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+
+ install -D -m755 ../apcupsd $startdir/pkg/etc/rc.d/apcupsd && \
+ chmod 755 $startdir/pkg/sbin/*
+}
diff --git a/apcupsd-cli/apcupsd b/apcupsd-cli/apcupsd
new file mode 100755
index 0000000..3cd5c9d
--- /dev/null
+++ b/apcupsd-cli/apcupsd
@@ -0,0 +1,44 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /sbin/apcupsd`
+case "$1" in
+ start)
+ stat_busy "Starting APCUPSD Daemon"
+ rm -f /etc/apcupsd/powerfail
+ rm -f /etc/nologin
+ [ -z "$PID" ] && /sbin/apcupsd -f /etc/apcupsd/apcupsd.conf
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ PID=`pidof -o %PPID /sbin/apcupsd`
+ echo $PID > /var/run/apcupsd.pid
+ add_daemon apcupsd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping APCUPSD Daemon"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm /var/run/apcupsd.pid
+ rm_daemon apcupsd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ status)
+ /sbin/apcaccess status
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart|status}"
+esac
+exit 0
diff --git a/arno-iptables-firewall/PKGBUILD b/arno-iptables-firewall/PKGBUILD
index 23ed3df..c6aa888 100644
--- a/arno-iptables-firewall/PKGBUILD
+++ b/arno-iptables-firewall/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Arto Puranen <purcher@gmail.com>
pkgname=arno-iptables-firewall
-pkgver=1.9.2d
+pkgver=1.9.2k
pkgrel=1
pkgdesc="A secure stateful firewall for both single and multi-homed machine"
arch=('i686' 'x86_64')
url=("http://rocky.eld.leidenuniv.nl/joomla/")
license=('GPL')
-depends=('iptables')
+depends=('iptables' 'iproute2')
makedepends=('patch')
backup=(etc/${pkgname}/firewall.conf
etc/${pkgname}/custom-rules
@@ -26,48 +26,42 @@ backup=(etc/${pkgname}/firewall.conf
etc/${pkgname}/plugins/traffic-accounting.conf
etc/${pkgname}/plugins/traffic-shaper.conf
etc/${pkgname}/plugins/transparent-dnat.conf
- etc/${pkgname}/plugins/transparent-proxy.conf
- etc/${pkgname}/plugins/hfsc.conf
- etc/${pkgname}/plugins/linuxigd.conf
- etc/${pkgname}/plugins/racoon-ipsec-vpn.conf
- etc/${pkgname}/plugins/ssh-brute-force-protection.conf)
-
+ etc/${pkgname}/plugins/transparent-proxy.conf)
source=(http://rocky.eld.leidenuniv.nl/${pkgname}/${pkgname}_${pkgver}.tar.gz \
${pkgname}.script \
${pkgname}.patch)
-
-md5sums=('f6a3f1fbc3dac2790fe95f36587d14d8'
+md5sums=('deb2d96773c72667a0279cb1ee3f163c'
'0c3de10c23359728a3bd90a521d3eebc'
- 'b46d833af9c0870c71ce82ec73dcbab4')
+ '0293d8034bd83cf88bc914f875f7dca6')
build() {
cd ${srcdir}/${pkgname}_${pkgver}
-### patch's
- patch etc/${pkgname}/firewall.conf ../${pkgname}.patch || return 1
+# patch
+ patch -Np0 -i ${srcdir}/${pkgname}.patch || return 1
-### conf files
+# conf files
install -d -m 0755 etc/${pkgname}/plugins/ ${pkgdir}/etc/${pkgname}/plugins/ || return 1
for i in `find etc/${pkgname} -type f`; do install -T -m 0600 $i ${pkgdir}/$i ;done
install -D -m 0644 share/${pkgname}/environment ${pkgdir}/usr/share/${pkgname}/environment || return 1
-### plugins
+# plugins
install -d -m 0755 share/${pkgname}/plugins/ ${pkgdir}/usr/share/${pkgname}/plugins/ || return 1
for i in share/${pkgname}/plugins/*plugin; do install -T -m 0644 $i ${pkgdir}/usr/$i ;done
-
-### binary
- install -D -m 0744 bin/${pkgname} ${pkgdir}/usr/sbin/${pkgname} || return 1
- install -D -m 0744 bin/arno-fwfilter ${pkgdir}/usr/sbin/arno-fwfilter || return 1
- install -D -m 0744 contrib/adsl-failover ${pkgdir}/usr/sbin/adsl-failover || return 1
install -D -m 0744 share/${pkgname}/plugins/dyndns-host-open-helper ${pkgdir}/usr/share/${pkgname}/plugins/dyndns-host-open-helper || return 1
install -D -m 0744 share/${pkgname}/plugins/traffic-accounting-helper ${pkgdir}/usr/share/${pkgname}/plugins/traffic-accounting-helper || return 1
install -D -m 0744 share/${pkgname}/plugins/traffic-accounting-log-rotate ${pkgdir}/usr/share/${pkgname}/plugins/traffic-accounting-log-rotate || return 1
install -D -m 0744 share/${pkgname}/plugins/traffic-accounting-show ${pkgdir}/usr/share/${pkgname}/plugins/traffic-accounting-show || return 1
-### man files
+# binary
+ install -D -m 0744 bin/${pkgname} ${pkgdir}/usr/sbin/${pkgname} || return 1
+ install -D -m 0744 bin/arno-fwfilter ${pkgdir}/usr/sbin/arno-fwfilter || return 1
+ install -D -m 0744 contrib/adsl-failover ${pkgdir}/usr/sbin/adsl-failover || return 1
+
+# man files
install -D -m 0644 share/man/man1/arno-fwfilter.1 ${pkgdir}/usr/share/man/man1/arno-fwfilter.1 || return 1
install -D -m 0644 share/man/man8/${pkgname}.8 ${pkgdir}/usr/share/man/man8/${pkgname}.8 || return 1
-### daemon script
+# daemon script
install -D -m 0744 ${srcdir}/${pkgname}.script ${pkgdir}/etc/rc.d/${pkgname} || return 1
-} \ No newline at end of file
+}
diff --git a/arno-iptables-firewall/arno-iptables-firewall.patch b/arno-iptables-firewall/arno-iptables-firewall.patch
index e045156..6acd49b 100644
--- a/arno-iptables-firewall/arno-iptables-firewall.patch
+++ b/arno-iptables-firewall/arno-iptables-firewall.patch
@@ -1,7 +1,6 @@
-diff -ruN arno-iptables-firewall_1.9.2b-orig/etc/arno-iptables-firewall/firewall.conf arno-iptables-firewall_1.9.2b/etc/arno-iptables-firewall/firewall.conf
---- arno-iptables-firewall_1.9.2b-orig/etc/arno-iptables-firewall/firewall.conf 2009-05-06 15:20:08.000000000 +0200
-+++ arno-iptables-firewall_1.9.2b/etc/arno-iptables-firewall/firewall.conf 2009-08-02 08:58:47.000000000 +0200
-@@ -180,20 +180,20 @@
+--- etc/arno-iptables-firewall/firewall.conf.orig 2010-02-26 08:09:05.000000000 +0100
++++ etc/arno-iptables-firewall/firewall.conf 2010-03-17 14:09:02.000000000 +0100
+@@ -185,20 +185,20 @@
# (EXPERT SETTING!) Location of the iptables-binary (use 'locate iptables' or
# 'whereis iptables' to manually locate it), required for (default) IPv4 support
# -----------------------------------------------------------------------------
diff --git a/perl-universal-require/PKGBUILD b/perl-universal-require/PKGBUILD
new file mode 100644
index 0000000..31d9467
--- /dev/null
+++ b/perl-universal-require/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Marvin Lampe <marvin.lampe@gmx.de>
+pkgname=perl-universal-require
+pkgver=0.13
+pkgrel=1
+pkgdesc='UNIVERSAL::require - require() modules from a variable'
+arch=('x86_64' 'i686')
+url='http://search.cpan.org/~mschwern/UNIVERSAL-require-0.13/lib/UNIVERSAL/require.pm'
+license=('GPL' 'Artistic License')
+makedepends=('perl')
+source=(http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/UNIVERSAL-require-${pkgver}.tar.gz)
+md5sums=('e6ea431fac9524077414d531a8cc203c')
+
+build() {
+ cd ${srcdir}/UNIVERSAL-require-${pkgver} || return 1
+ perl Makefile.PL || return 1
+ make || return 1
+ mkdir -p ${pkgdir}/usr/lib/perl5/vendor_perl/UNIVERSAL || return 1
+ mkdir -p ${pkgdir}/usr/share/man/man3 || return 1
+ cp ${srcdir}/UNIVERSAL-require-${pkgver}/blib/lib/UNIVERSAL/require.pm ${pkgdir}/usr/lib/perl5/vendor_perl/UNIVERSAL || return 1
+ cp ${srcdir}/UNIVERSAL-require-${pkgver}/blib/man3/UNIVERSAL::require.3pm ${pkgdir}/usr/share/man/man3
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/radvd/PKGBUILD b/radvd/PKGBUILD
new file mode 100644
index 0000000..8a36e8c
--- /dev/null
+++ b/radvd/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Mark Smith <markzzzsmith@yahoo.com.au>
+pkgname=radvd
+pkgver=1.6
+pkgrel=1
+pkgdesc="IPv6 Router Advertisement / Router Solicitation daemon"
+url="http://www.litech.org/radvd/"
+license="custom"
+arch=('i686' 'x86_64')
+makedepends=('automake' 'gcc' 'coreutils' 'sed' 'bison' 'flex' \
+ 'tar' 'gzip' 'glibc' )
+depends=('glibc')
+backup=(etc/$pkgname/radvd.conf)
+install=radvd.install
+source=(http://www.litech.org/radvd/dist/$pkgname-$pkgver.tar.gz
+ radvd.rc.d
+ radvd.install)
+md5sums=('987e0660d68b4501b24dc5a068cea83c'
+ '0ceec38160497fb99ca6879c27e9255a'
+ 'b02517cc251dba4a2910395de878bde9')
+
+build() {
+
+ cd $startdir/src/$pkgname-$pkgver
+
+ ./configure --prefix=/usr\
+ --sysconfdir=/etc/$pkgname \
+ --mandir=/usr/share/man
+
+ make
+
+ make DESTDIR=$startdir/pkg install
+
+ install -D -m444 COPYRIGHT $startdir/pkg/usr/share/licenses/$pkgname/COPYRIGHT
+ install -D -m444 $startdir/src/$pkgname-$pkgver/radvd.conf.example \
+ $startdir/pkg/etc/$pkgname/radvd.conf.example
+
+ install -D -m755 $startdir/radvd.rc.d $startdir/pkg/etc/rc.d/radvd
+
+}
diff --git a/radvd/radvd.install b/radvd/radvd.install
new file mode 100644
index 0000000..c049cbd
--- /dev/null
+++ b/radvd/radvd.install
@@ -0,0 +1,57 @@
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+
+ cat << EOF
+
+NOTE
+----
+
+radvd requires IPv6 forwarding be enabled. To enable IPv6 forwarding at
+boot time, add the following to /etc/sysctl.conf:
+
+ # Enable IPv6 packet forwarding
+ net.ipv6.conf.all.forwarding = 1
+
+or manually enable forwarding using:
+
+ echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
+
+EOF
+
+ /bin/true
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+
+ # clean up just in case
+ rm -f /var/run/radvd.pid
+
+}
+
+op=$1
+shift
+$op $*
diff --git a/radvd/radvd.rc.d b/radvd/radvd.rc.d
new file mode 100644
index 0000000..971bc41
--- /dev/null
+++ b/radvd/radvd.rc.d
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/radvd`
+case "$1" in
+ start)
+ stat_busy "Starting radvd IPv6 RA/RS daemon"
+ if [ -z "$PID" ]; then
+ /usr/sbin/radvd
+ fi
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon radvd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping radvd IPv6 RA/RS daemon"
+ [ ! -z "$PID" ] && kill $PID &>/dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon radvd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
diff --git a/rtorrent-color/PKGBUILD b/rtorrent-color/PKGBUILD
new file mode 100644
index 0000000..d44c680
--- /dev/null
+++ b/rtorrent-color/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ashren <edgar [at] archlinux [dot] us>
+
+pkgname=rtorrent-color
+pkgver=0.8.6
+pkgrel=5
+pkgdesc="Ncurses BitTorrent client based on libTorrent with color patch."
+arch=('i686' 'x86_64')
+url="http://libtorrent.rakshasa.no"
+install=$pkgname.install
+license=('GPL')
+depends=('libtorrent=0.12.6' 'curl>=7.14.3' 'xmlrpc-c')
+source=(http://libtorrent.rakshasa.no/downloads/rtorrent-$pkgver.tar.gz rtorrent-0.8.6-canvas-fix.patch)
+conflicts=('rtorrent')
+
+md5sums=('b804c45c01c40312926bcea6b55bb084'
+ '03cbbf61ac0c5a128880a5a453677a87')
+
+build() {
+ cd "$srcdir/rtorrent-$pkgver"
+ patch -p1 < $startdir/src/rtorrent-0.8.6-canvas-fix.patch
+ CXXFLAGS="$CXXFLAGS -fno-strict-aliasing" \
+ ./configure --prefix=/usr --disable-debug --with-xmlrpc-c || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+
+# vim:set ts=2 sw=2 et:
diff --git a/rtorrent-color/rtorrent-0.8.4-SVN-canvas-fix.patch.part b/rtorrent-color/rtorrent-0.8.4-SVN-canvas-fix.patch.part
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/rtorrent-color/rtorrent-0.8.4-SVN-canvas-fix.patch.part
diff --git a/rtorrent-color/rtorrent-0.8.5.tar.gz.part b/rtorrent-color/rtorrent-0.8.5.tar.gz.part
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/rtorrent-color/rtorrent-0.8.5.tar.gz.part
diff --git a/rtorrent-color/rtorrent-0.8.6-canvas-fix.patch b/rtorrent-color/rtorrent-0.8.6-canvas-fix.patch
new file mode 100644
index 0000000..02b8a18
--- /dev/null
+++ b/rtorrent-color/rtorrent-0.8.6-canvas-fix.patch
@@ -0,0 +1,321 @@
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/command_network.cc ./src/command_network.cc
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/command_network.cc 2009-11-12 09:19:40.000000000 +0100
+--- ./src/command_network.cc 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 495,498 ****
+--- 495,502 ----
+ // Not really network stuff:
+ ADD_VARIABLE_BOOL ("handshake_log", false);
+ ADD_VARIABLE_STRING("log.tracker", "");
++ ADD_COMMAND_VALUE_TRI("done_fg_color", rak::make_mem_fun(control->ui(), &ui::Root::set_done_fg_color), rak::make_mem_fun(control->ui(), &ui::Root::get_done_fg_color));
++ ADD_COMMAND_VALUE_TRI("done_bg_color", rak::make_mem_fun(control->ui(), &ui::Root::set_done_bg_color), rak::make_mem_fun(control->ui(), &ui::Root::get_done_bg_color));
++ ADD_COMMAND_VALUE_TRI("active_fg_color", rak::make_mem_fun(control->ui(), &ui::Root::set_active_fg_color), rak::make_mem_fun(control->ui(), &ui::Root::get_active_fg_color));
++ ADD_COMMAND_VALUE_TRI("active_bg_color", rak::make_mem_fun(control->ui(), &ui::Root::set_active_bg_color), rak::make_mem_fun(control->ui(), &ui::Root::get_active_bg_color));
+ }
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/display/canvas.cc ./src/display/canvas.cc
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/display/canvas.cc 2009-11-12 09:03:47.000000000 +0100
+--- ./src/display/canvas.cc 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 92,97 ****
+--- 92,101 ----
+ m_isInitialized = true;
+
+ initscr();
++ start_color();
++ use_default_colors();
++ init_pair(2, -1, -1);
++ init_pair(1, -1, -1);
+ raw();
+ noecho();
+ nodelay(stdscr, TRUE);
+Only in ./src/display: canvas.cc.orig
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/display/window_download_list.cc ./src/display/window_download_list.cc
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/display/window_download_list.cc 2009-11-12 09:03:47.000000000 +0100
+--- ./src/display/window_download_list.cc 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 37,42 ****
+--- 37,43 ----
+ #include "config.h"
+
+ #include <rak/algorithm.h>
++ #include <torrent/rate.h>
+
+ #include "core/download.h"
+ #include "core/view.h"
+***************
+*** 96,107 ****
+ char* position;
+ char* last = buffer + m_canvas->width() - 2 + 1;
+
+ position = print_download_title(buffer, last, *range.first);
+! m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+
+ position = print_download_info(buffer, last, *range.first);
+ m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+
+ position = print_download_status(buffer, last, *range.first);
+ m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+
+--- 97,126 ----
+ char* position;
+ char* last = buffer + m_canvas->width() - 2 + 1;
+
++ if( pos >= m_canvas->height() ) break;
+ position = print_download_title(buffer, last, *range.first);
+! m_canvas->print(0, pos, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+! if( (*range.first)->is_done() ) {
+! if( (*range.first)->download()->up_rate()->rate() != 0 ) {
+! m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 2);
+! } else {
+! m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 2);
+! }
+! } else if( (*range.first)->download()->is_active() ) {
+! if( (*range.first)->download()->down_rate()->rate() != 0 ) {
+! m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 1);
+! } else {
+! m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 1);
+! }
+! }
+! pos++;
+
++ if( pos >= m_canvas->height() ) break;
++
+ position = print_download_info(buffer, last, *range.first);
+ m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+
++ if( pos >= m_canvas->height() ) break;
+ position = print_download_status(buffer, last, *range.first);
+ m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
+
+***************
+*** 109,112 ****
+--- 128,167 ----
+ }
+ }
+
++ void
++ WindowDownloadList::set_done_fg_color(int64_t color) {
++ short fg, bg;
++ pair_content(2, &fg, &bg);
++ if( color < 0 ) color = -1;
++ color = color % 8;
++ init_pair(2, (short)color, bg);
++ }
++
++ void
++ WindowDownloadList::set_done_bg_color(int64_t color) {
++ short fg, bg;
++ pair_content(2, &fg, &bg);
++ if( color < 0 ) color = -1;
++ color = color % 8;
++ init_pair(2, fg, (short)color);
++ }
++
++ void
++ WindowDownloadList::set_active_fg_color(int64_t color) {
++ short fg, bg;
++ pair_content(1, &fg, &bg);
++ if( color < 0 ) color = -1;
++ color = color % 8;
++ init_pair(1, (short)color, bg);
++ }
++
++ void
++ WindowDownloadList::set_active_bg_color(int64_t color) {
++ short fg, bg;
++ pair_content(1, &fg, &bg);
++ if( color < 0 ) color = -1;
++ color = color % 8;
++ init_pair(1, fg, (short)color);
++ }
++
+ }
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/display/window_download_list.h ./src/display/window_download_list.h
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/display/window_download_list.h 2009-11-12 09:03:47.000000000 +0100
+--- ./src/display/window_download_list.h 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 59,64 ****
+--- 59,68 ----
+ virtual void redraw();
+
+ void set_view(core::View* l);
++ void set_done_fg_color(int64_t color);
++ void set_done_bg_color(int64_t color);
++ void set_active_fg_color(int64_t color);
++ void set_active_bg_color(int64_t color);
+
+ private:
+ core::View* m_view;
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/download_list.cc ./src/ui/download_list.cc
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/download_list.cc 2009-11-12 09:03:48.000000000 +0100
+--- ./src/ui/download_list.cc 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 137,142 ****
+--- 137,147 ----
+ current_view()->next_focus();
+ }
+
++ display::WindowDownloadList*
++ DownloadList::current_window_list() {
++ return dynamic_cast<ElementDownloadList*>(m_uiArray[DISPLAY_DOWNLOAD_LIST])->window();
++ }
++
+ void
+ DownloadList::activate_display(Display displayType) {
+ if (!is_active())
+Only in ./src/ui: download_list.cc.orig
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/download_list.h ./src/ui/download_list.h
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/download_list.h 2009-11-12 09:03:48.000000000 +0100
+--- ./src/ui/download_list.h 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 101,106 ****
+--- 101,107 ----
+ void activate_display(Display d);
+
+ core::View* current_view();
++ display::WindowDownloadList* current_window_list();
+ void set_current_view(const std::string& name);
+
+ void slot_open_uri(SlotOpenUri s) { m_slotOpenUri = s; }
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/element_download_list.h ./src/ui/element_download_list.h
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/element_download_list.h 2009-11-12 09:03:48.000000000 +0100
+--- ./src/ui/element_download_list.h 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 60,65 ****
+--- 60,66 ----
+ void disable();
+
+ core::View* view() { return m_view; }
++ WDownloadList* window() { return m_window; }
+ void set_view(core::View* l);
+
+ void receive_command(const char* cmd);
+Only in ./src/ui: element_download_list.h.orig
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/root.cc ./src/ui/root.cc
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/root.cc 2009-11-12 09:03:48.000000000 +0100
+--- ./src/ui/root.cc 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 44,49 ****
+--- 44,50 ----
+
+ #include "core/manager.h"
+ #include "display/frame.h"
++ #include "display/window_download_list.h"
+ #include "display/window_http_queue.h"
+ #include "display/window_title.h"
+ #include "display/window_input.h"
+***************
+*** 65,71 ****
+ m_windowTitle(NULL),
+ m_windowHttpQueue(NULL),
+ m_windowInput(NULL),
+! m_windowStatusbar(NULL) {
+ }
+
+ void
+--- 66,76 ----
+ m_windowTitle(NULL),
+ m_windowHttpQueue(NULL),
+ m_windowInput(NULL),
+! m_windowStatusbar(NULL),
+! done_fg_color(-1),
+! done_bg_color(-1),
+! active_fg_color(-1),
+! active_bg_color(-1) {
+ }
+
+ void
+***************
+*** 97,102 ****
+--- 102,111 ----
+ setup_keys();
+
+ m_downloadList->activate(rootFrame->frame(1));
++ m_downloadList->current_window_list()->set_done_fg_color(done_fg_color);
++ m_downloadList->current_window_list()->set_done_bg_color(done_bg_color);
++ m_downloadList->current_window_list()->set_active_fg_color(active_fg_color);
++ m_downloadList->current_window_list()->set_active_bg_color(active_bg_color);
+ }
+
+ void
+***************
+*** 219,224 ****
+--- 228,273 ----
+ torrent::set_max_unchoked(maxUnchoked);
+ }
+
++ int
++ Root::get_done_fg_color() {
++ return done_fg_color;
++ }
++
++ void
++ Root::set_done_fg_color(int64_t color) {
++ done_fg_color = color;
++ }
++
++ int
++ Root::get_done_bg_color() {
++ return done_bg_color;
++ }
++
++ void
++ Root::set_done_bg_color(int64_t color) {
++ done_bg_color = color;
++ }
++
++ int
++ Root::get_active_fg_color() {
++ return active_fg_color;
++ }
++
++ void
++ Root::set_active_fg_color(int64_t color) {
++ active_fg_color = color;
++ }
++
++ int
++ Root::get_active_bg_color() {
++ return active_bg_color;
++ }
++
++ void
++ Root::set_active_bg_color(int64_t color) {
++ active_bg_color = color;
++ }
++
+ void
+ Root::adjust_down_throttle(int throttle) {
+ set_down_throttle(std::max<int>(torrent::down_throttle_global()->max_rate() / 1024 + throttle, 0));
+Only in ./src/ui: root.cc.orig
+diff -crB /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/root.h ./src/ui/root.h
+*** /home/regj/misc/rtorrent-color-orig/src/rtorrent-0.8.6/src/ui/root.h 2009-11-12 09:03:48.000000000 +0100
+--- ./src/ui/root.h 2009-12-17 19:27:05.783955715 +0100
+***************
+*** 82,87 ****
+--- 82,95 ----
+ // Rename to raw or something, make base function.
+ void set_down_throttle_i64(int64_t throttle) { set_down_throttle(throttle >> 10); }
+ void set_up_throttle_i64(int64_t throttle) { set_up_throttle(throttle >> 10); }
++ int get_done_fg_color();
++ void set_done_fg_color(int64_t color);
++ int get_done_bg_color();
++ void set_done_bg_color(int64_t color);
++ int get_active_fg_color();
++ void set_active_fg_color(int64_t color);
++ int get_active_bg_color();
++ void set_active_bg_color(int64_t color);
+
+ void adjust_down_throttle(int throttle);
+ void adjust_up_throttle(int throttle);
+***************
+*** 105,110 ****
+--- 113,122 ----
+ WStatusbar* m_windowStatusbar;
+
+ input::Bindings m_bindings;
++ int64_t done_fg_color;
++ int64_t done_bg_color;
++ int64_t active_fg_color;
++ int64_t active_bg_color;
+ };
diff --git a/rtorrent-color/rtorrent-color.install b/rtorrent-color/rtorrent-color.install
new file mode 100644
index 0000000..86facb4
--- /dev/null
+++ b/rtorrent-color/rtorrent-color.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo ""
+ echo "Set colors using the options below in .rtorrent.rc:"
+ echo "Options: done_fg_color, done_bg_color, active_fg_color, active_bg_color"
+ echo "Colors: 0 = black 1 = red 2 = green 3 = yellow 4 = blue 5 = magenta 6 = cyan 7 = white"
+ echo "Example: done_fg_color = 1"
+}
+post_upgrade() {
+ post_install
+}
+
diff --git a/rtorrent-extended/PKGBUILD b/rtorrent-extended/PKGBUILD
index 532273f..52ebeb4 100644
--- a/rtorrent-extended/PKGBUILD
+++ b/rtorrent-extended/PKGBUILD
@@ -115,7 +115,7 @@ build() {
./autogen.sh
CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing" \
- ./configure --prefix=/usr --disable-debug ${_option_ipv6} --with-xmlrpc-c || return 1
+ ./configure --prefix=/usr --enable-posix-fallocate --disable-debug ${_option_ipv6} --with-xmlrpc-c || return 1
make || return 1
make DESTDIR="${pkgdir}" install
}