summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tipp10/PKGBUILD16
-rw-r--r--tipp10/defines.h.patch16
2 files changed, 22 insertions, 10 deletions
diff --git a/tipp10/PKGBUILD b/tipp10/PKGBUILD
index bc12ec9..d37bd47 100644
--- a/tipp10/PKGBUILD
+++ b/tipp10/PKGBUILD
@@ -3,20 +3,21 @@
pkgname=tipp10
pkgver=2.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="intelligent typing tutor (german only)"
arch=('i686' 'x86_64')
url="http://www.tipp10.de/"
license=('GPL2')
depends=('qt>=4.2.2')
makedepends=('unzip' 'make')
-source=(tipp10.desktop tipp10.png \
- "http://flo.server-speed.net/stuff/mirror/tipp10_source_v2-0-3.zip")
+source=(tipp10.desktop tipp10.png defines.h.patch \
+ "http://www.tipp10.de/download_hidden/tipp10_source_v2-0-3.zip")
build() {
sed -i 's/tipp10v2.template/..\/share\/tipp10\/tipp10v2.template/' $srcdir/tipp10/def/defines.h
cd $srcdir/tipp10
+ patch -p0 < "$srcdir/defines.h.patch" || return 1
qmake
make || return 1
install -D tipp10 $pkgdir/usr/bin/tipp10
@@ -24,16 +25,11 @@ build() {
install -D $srcdir/tipp10.png $pkgdir/usr/share/pixmaps/tipp10.png
install -D $srcdir/tipp10.desktop $pkgdir/usr/share/applications/tipp10.desktop
}
-
-md5sums=('e0d6c26220396551386f91ce893e040c'
- 'ff788e726d357370df1e7c8b19d38fd4'
- 'bac29896ec992496f7e0aab992993004')
-sha256sums=('ed18e5cb625463595ca4d84c9e4576d42af407c31a29a76e2bc7a8538288d35d'
- '83c2574c3ba23b3344669bf15cbd618dfe8ddc3863bdfce1d70ba22200bd8ff0'
- 'bf44edc1524b8dac07c0d501368411cc13e5c1a2a6ffb0d1b4d576ba1ad80fd5')
md5sums=('e0d6c26220396551386f91ce893e040c'
'ff788e726d357370df1e7c8b19d38fd4'
+ 'ce67b64cb3a1d25119acd1a43804304d'
'bac29896ec992496f7e0aab992993004')
sha256sums=('ed18e5cb625463595ca4d84c9e4576d42af407c31a29a76e2bc7a8538288d35d'
'83c2574c3ba23b3344669bf15cbd618dfe8ddc3863bdfce1d70ba22200bd8ff0'
+ '02e5791a64b4881d0edd87e28d1f161aba228ac77b1d657814c105c2c4eba88f'
'bf44edc1524b8dac07c0d501368411cc13e5c1a2a6ffb0d1b4d576ba1ad80fd5')
diff --git a/tipp10/defines.h.patch b/tipp10/defines.h.patch
new file mode 100644
index 0000000..4ff291c
--- /dev/null
+++ b/tipp10/defines.h.patch
@@ -0,0 +1,16 @@
+--- def/defines.h.orig 2009-03-09 13:02:26.000000000 +0100
++++ def/defines.h 2009-03-09 13:02:41.000000000 +0100
+@@ -27,10 +27,10 @@
+ #define DEFINES_H
+
+ // OS constants
+-#define APP_WIN true
++#define APP_WIN false
+ #define APP_MAC false
+-#define APP_X11 false
+-#define APP_PORTABLE true //at least one of the 3 OS must be true too!
++#define APP_X11 true
++#define APP_PORTABLE false //at least one of the 3 OS must be true too!
+
+ // Common program constants
+ #define APP_ORGANIZATION "Tom Thielicke IT Solutions"