summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recalulate_sums.sh10
1 files changed, 10 insertions, 0 deletions
diff --git a/recalulate_sums.sh b/recalulate_sums.sh
index e41ca5d..a24e5a1 100644
--- a/recalulate_sums.sh
+++ b/recalulate_sums.sh
@@ -1 +1,11 @@
+#!/bin/sh
+
+# sed line from upgpkg
sed -r '/.*sums[ ]?\=/{:a; /\)/d; N; ba;}' */PKGBUILD -i
+
+for folder in */; do
+ pushd .
+ cd $folder
+ makepkg -g >> PKGBUILD
+ popd
+done