summaryrefslogtreecommitdiffstats
path: root/foo2zjs/foo2zjs-20091017-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'foo2zjs/foo2zjs-20091017-Makefile.patch')
-rw-r--r--foo2zjs/foo2zjs-20091017-Makefile.patch180
1 files changed, 180 insertions, 0 deletions
diff --git a/foo2zjs/foo2zjs-20091017-Makefile.patch b/foo2zjs/foo2zjs-20091017-Makefile.patch
new file mode 100644
index 0000000..f2e04de
--- /dev/null
+++ b/foo2zjs/foo2zjs-20091017-Makefile.patch
@@ -0,0 +1,180 @@
+--- a/Makefile 2009-10-10 04:28:28.000000000 -0700
++++ b/Makefile 2009-10-19 01:02:24.000000000 -0700
+@@ -17,7 +17,6 @@
+
+ # Installation prefix...
+ PREFIX=/usr/local
+-PREFIX=/usr
+ PREFIX=$(DESTDIR)/usr
+
+ # Pathnames for this package...
+@@ -35,7 +34,7 @@
+ INSTALL=install
+
+ # Pathnames for referenced packages...
+-FOODB=$(DESTDIR)/usr/share/foomatic/db/source
++FOODB=$(PREFIX)/share/foomatic/db/source
+
+ # User ID's
+ LPuid=-oroot
+@@ -255,7 +254,7 @@
+ endif
+
+ # Compiler flags
+-CFLAGS += -O2 -Wall
++CFLAGS ?= -O2 -Wall
+ #CFLAGS += -g
+
+ #
+@@ -547,6 +546,8 @@
+ UDEVBIN=$(DESTDIR)/bin/
+
+ install-prog:
++ [ -d $(BIN) ] || install -d -m 755 $(BIN)/
++ [ -d $(DESTDIR)/bin/ ] || install -d -m 755 $(DESTDIR)/bin/
+ #
+ # Install driver, wrapper, and development tools
+ #
+@@ -554,7 +555,7 @@
+ $(INSTALL) -c $(PROGS) $(SHELLS) $(BIN)/
+ if [ "$(BINPROGS)" != "" ]; then \
+ $(INSTALL) -d $(UDEVBIN); \
+- $(INSTALL) -c $(BINPROGS) $(UDEVBIN); \
++ install -c $(BINPROGS) $(DESTDIR)/bin/; \
+ fi
+ #
+ # Install gamma correction files. These are just templates,
+@@ -588,6 +589,7 @@
+ #
+ @if [ -d $(FOODB) ]; then \
+ for dir in driver printer opt; do \
++ [ -d $(FOODB)/$$dir/ ] || install -d -m 755 $(FOODB)/$$dir/; \
+ echo install -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
+ $(INSTALL) -c -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
+ done \
+@@ -605,10 +607,10 @@
+ #
+ # Clear foomatic cache and rebuild database if needed
+ #
+- rm -rf /var/cache/foomatic/*/*
+- rm -f /var/cache/foomatic/printconf.pickle
+- if [ -d /var/cache/foomatic/compiled ]; then \
+- cd /var/cache/foomatic/compiled; \
++ rm -rf $(DESTDIR)/var/cache/foomatic/*/*
++ rm -f $(DESTDIR)/var/cache/foomatic/printconf.pickle
++ if [ -d $(DESTDIR)/var/cache/foomatic/compiled ]; then \
++ cd $(DESTDIR)/var/cache/foomatic/compiled; \
+ foomatic-combo-xml -O >overview.xml; \
+ fi
+
+@@ -722,9 +724,9 @@
+ fi; \
+ done
+
+-MODEL=$(DESTDIR)/usr/share/cups/model
++MODEL=$(PREFIX)/share/cups/model
+ LOCALMODEL=$(DESTDIR)/usr/local/share/cups/model
+-PPD=$(DESTDIR)/usr/share/ppd
++PPD=$(PREFIX)/share/ppd
+ VARPPD=/var/lp/ppd
+ install-ppd:
+ #
+@@ -740,13 +742,6 @@
+ done; \
+ ppdmgr -u; \
+ elif [ -d $(PPD) ]; then \
+- find $(PPD) -name '*foo2zjs*' | xargs rm -rf; \
+- find $(PPD) -name '*foo2hp*' | xargs rm -rf; \
+- find $(PPD) -name '*foo2xqx*' | xargs rm -rf; \
+- find $(PPD) -name '*foo2lava*' | xargs rm -rf; \
+- find $(PPD) -name '*foo2qpdl*' | xargs rm -rf; \
+- find $(PPD) -name '*foo2slx*' | xargs rm -rf; \
+- find $(PPD) -name '*foo2hiperc*' | xargs rm -rf; \
+ [ -d $(PPD)/foo2zjs ] || mkdir $(PPD)/foo2zjs; \
+ cd PPD; \
+ for ppd in *.ppd; do \
+@@ -767,9 +762,9 @@
+ done; \
+ fi
+
+-APPL=$(DESTDIR)/usr/share/applications
+-OLDAPPL=$(DESTDIR)/usr/share/gnome/apps/System
+-PIXMAPS=$(DESTDIR)/usr/share/pixmaps
++APPL=$(PREFIX)/share/applications
++OLDAPPL=$(PREFIX)/share/gnome/apps/System
++PIXMAPS=$(PREFIX)/share/pixmaps
+
+ install-desktop:
+ #
+@@ -793,10 +788,8 @@
+ $(INSTALL) -c -m 755 hplj10xx_gui.tcl $(SHAREZJS)
+
+
+-USBDIR=/etc/hotplug/usb
+-UDEVDIR=/etc/udev/rules.d
+-RULES=hplj10xx.rules
+-install-hotplug: install-hotplug-test install-hotplug-prog
++USBDIR=$(DESTDIR)/etc/hotplug/usb
++install-hotplug: install-hotplug-test install-udev
+
+ install-hotplug-test:
+ #
+@@ -814,9 +807,6 @@
+ #
+
+ install-hotplug-prog:
+- if [ -d $(UDEVDIR) ]; then \
+- $(INSTALL) -c -m 644 $(RULES) $(UDEVDIR)/11-$(RULES); \
+- fi
+ [ -d $(USBDIR) ] || $(INSTALL) -d -m 755 $(USBDIR)/
+ $(INSTALL) -c -m 755 hplj1000 $(USBDIR)/
+ ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1005
+@@ -827,17 +817,13 @@
+ ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1007
+ ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1008
+ ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1505
+- $(USBDIR)/hplj1000 install-usermap
+- $(USBDIR)/hplj1005 install-usermap
+- $(USBDIR)/hplj1018 install-usermap
+- $(USBDIR)/hplj1020 install-usermap
+- $(USBDIR)/hpljP1005 install-usermap
+- $(USBDIR)/hpljP1006 install-usermap
+- $(USBDIR)/hpljP1007 install-usermap
+- $(USBDIR)/hpljP1008 install-usermap
+- $(USBDIR)/hpljP1505 install-usermap
+- # modprobe usblp
+- $(USBDIR)/hplj1000 install-usblp
++ install -c -m 644 hplj.usermap $(USBDIR)/
++
++UDEVDIR=$(DESTDIR)/lib/udev/rules.d
++RULES=hplj10xx.rules
++install-udev:
++ [ -d $(UDEVDIR) ] || install -d -m 755 $(UDEVDIR)/
++ install -c -m 644 $(RULES) $(UDEVDIR)/11-$(RULES)
+
+ cups: FRC
+ if [ -x /etc/init.d/cups ]; then \
+@@ -1234,7 +1220,6 @@
+ $(INSTALL) -c -m 644 README $(DOCDIR)
+ $(INSTALL) -c -m 644 ChangeLog $(DOCDIR)
+
+-GROFF=/usr/local/test/bin/groff
+ GROFF=groff
+ manual.pdf: $(MANPAGES)
+ -$(GROFF) -t -man $(MANPAGES) | ps2pdf - $@
+--- a/icc2ps/Makefile 2007-11-27 12:13:53.000000000 -0900
++++ b/icc2ps/Makefile 2008-02-25 20:49:33.000000000 -0900
+@@ -1,11 +1,11 @@
+ UNAME := $(shell uname)
+-PREFIX= /usr
++PREFIX= $(DESTDIR)/usr
+ BIN= $(PREFIX)/bin
+ SRC= icc2ps.c xgetopt.c
+ LIB= cmscam97.c cmscnvrt.c cmserr.c cmsgamma.c cmsgmt.c cmsintrp.c cmsio1.c \
+ cmslut.c cmsmatsh.c cmsmtrx.c cmsnamed.c cmspack.c cmspcs.c cmsps2.c \
+ cmssamp.c cmswtpnt.c cmsxform.c cmsio0.c cmsvirt.c
+-CFLAGS= -O3
++CFLAGS?= -O3
+ INSTALL=install
+ ifeq ($(UNAME),SunOS)
+ INSTALL=/usr/ucb/install