summaryrefslogtreecommitdiffstats
path: root/gajim-hg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gajim-hg/PKGBUILD')
-rw-r--r--gajim-hg/PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/gajim-hg/PKGBUILD b/gajim-hg/PKGBUILD
new file mode 100644
index 0000000..71a8de6
--- /dev/null
+++ b/gajim-hg/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Benjamin Richter <br@waldteufel-online.net>
+# Contributor: Changaco <changaco@changaco.net>
+# Contributor: Artyom Smirnov <smirnoffjr@gmail.com>
+
+pkgname=gajim-hg
+pkgver=11794
+pkgrel=1
+pkgdesc="Jabber/XMMP instant messenger client written in PyGTK"
+arch=('i686' 'x86_64')
+url="http://gajim.org"
+license=('GPL')
+depends=('python>=2.5' 'pygtk>=2.16' 'xdg-utils')
+makedepends=('mercurial' 'intltool>=0.40.1')
+optdepends=(
+ 'libxss: idle'
+ 'pyopenssl: secure SSL/TLS'
+ 'pycrypto: End to end encryption'
+ 'dbus-glib: link-local messaging (install avahi!)'
+ 'avahi: link-local messaging (install dbus-glib!)'
+ 'dnsutils: SRV support'
+ 'gtkspell: Spell checking (install aspell-LANG!)'
+ 'gnome-python-desktop: Keyring support'
+ 'python-notify: Notification popups'
+ 'dbus-python'
+ 'farsight2: for Jingle support')
+provides=('gajim')
+conflicts=('gajim' 'gajim-svn')
+replaces=('gajim-svn')
+options=(!libtool)
+install=gajim.install
+source=()
+md5sums=()
+
+_hgroot=http://hg.gajim.org
+_hgrepo=gajim
+
+build() {
+ rm -rf "{$srcdir}/build"
+
+ cd "${srcdir}/${_hgrepo}"
+ [[ $(hg branch) == default ]] || hg update default
+ hg archive "${srcdir}/build"
+
+ cd "${srcdir}/build"
+ ./autogen.sh --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}