summaryrefslogtreecommitdiffstats
path: root/nikto/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nikto/PKGBUILD')
-rw-r--r--nikto/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/nikto/PKGBUILD b/nikto/PKGBUILD
new file mode 100644
index 0000000..6b4c282
--- /dev/null
+++ b/nikto/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Arkham <arkham at archlinux dot us>
+# Contributor: Arkham <arkham at archlinux dot us>
+
+pkgname=nikto
+pkgver=2.1.1
+pkgrel=1
+pkgdesc='A web server scanner which performs comprehensive tests against web servers for multiple items'
+url='http://www.cirt.net/code/nikto.shtml'
+license=('GPL')
+arch=('any')
+depends=('perl' 'openssl' 'perl-net-ssleay')
+install=$pkgname.install
+source=(http://www.cirt.net/nikto/$pkgname-$pkgver.tar.gz
+ nikto.sh)
+md5sums=('a9404c3f464b08f3f48788d5f39e0ca7'
+ 'eb7b704c8bdae28af9a0353764d0b552')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ install -d $pkgdir/usr/share/nikto
+ cp -a * $pkgdir/usr/share/nikto/
+ find $pkgdir/usr/share/nikto -type f -exec chmod 644 {} +
+ install -Dm 755 $srcdir/nikto.sh $pkgdir/usr/bin/nikto
+}