summaryrefslogtreecommitdiffstats
path: root/perl-unix-syslog/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-unix-syslog/PKGBUILD')
-rw-r--r--perl-unix-syslog/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/perl-unix-syslog/PKGBUILD b/perl-unix-syslog/PKGBUILD
new file mode 100644
index 0000000..b6be3de
--- /dev/null
+++ b/perl-unix-syslog/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Piotr Beling <qwak@w8.pl>
+# Contributor: Wael Nasreddine <wael@phoenixlinux.org>
+# Maintainer: Guillermo A. Amaral <me@guillermoamaral.com> (thewonka)
+
+pkgname='perl-unix-syslog'
+pkgver='0.100'
+pkgrel='2'
+pkgdesc='Perl interface to the UNIX syslog calls.'
+url='http://search.cpan.org/~mharnisch/Unix-Syslog-0.100/'
+arch=('i686' 'x86_64')
+depends=('perl>=5.8.4')
+source=("http://search.cpan.org/CPAN/authors/id/M/MH/MHARNISCH/Unix-Syslog-${pkgver}.tar.gz")
+md5sums=('655d2e04a043b3e92d1bb47caf8e8a3b')
+install="${pkgname}.install"
+
+build()
+{
+
+ cd ${startdir}/src/Unix-Syslog-${pkgver}
+
+ eval $(perl -V:archname)
+
+ perl Makefile.PL INSTALLARCHLIB=/usr/lib/perl5/current/${archname} INSTALLSITELIB=/usr/lib/perl5/site_perl/current INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${archname}
+
+ make || return 1
+
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ find ${startdir}/pkg -name '.packlist' -exec rm -f {} \;
+ find ${startdir}/pkg -name 'perllocal.pod' -exec rm -f {} \;
+
+}