summaryrefslogtreecommitdiffstats
path: root/wireshark-cli/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'wireshark-cli/PKGBUILD')
-rw-r--r--wireshark-cli/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/wireshark-cli/PKGBUILD b/wireshark-cli/PKGBUILD
new file mode 100644
index 0000000..24736e9
--- /dev/null
+++ b/wireshark-cli/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Maintainer: Florian "Bluewind" Pritz <flo@xssn.at>
+
+pkgname=wireshark-cli
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="A free network protocol analyzer for Unix/Linux and Windows - no GUI"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('heimdal>=1.3.1' 'libpcap>=1.0.0' 'bash' 'gnutls>=2.4.1' 'libcap>=2.16')
+makedepends=('bison' 'flex')
+url="http://www.wireshark.org/"
+replaces=('ethereal')
+conflicts=('wireshark')
+options=(!libtool)
+source=(http://www.wireshark.org/download/src/wireshark-${pkgver}.tar.gz wireshark-1.1.2--as-needed.patch)
+
+build() {
+ cd ${srcdir}/wireshark-${pkgver}
+ export CFLAGS="-fno-unit-at-a-time ${CFLAGS}"
+
+ patch -Np1 -i $srcdir/wireshark-1.1.2--as-needed.patch || return 1
+ autoreconf -f -i || return 1
+
+ ./configure --prefix=/usr --with-ssl --disable-wireshark --disable-gtktest || return 1
+ make all || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}
+
+md5sums=('fdc1bc9815ee7ba067094edf60f7b9ff'
+ 'cc87d7eb31f256df751b3371b1c426e9')
+sha1sums=('525b9062674a2951f790a2621ddf14e5cea5be48'
+ '7a743a42542fa59423870a0205e8ed7aa6bde70e')