summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsimo <simo>2006-01-04 06:39:41 +0100
committersimo <simo>2006-01-04 06:39:41 +0100
commitabf907ea6ad4b2895bf2116a2878aac79c51d9eb (patch)
tree33dd93bd2ff1abd0ea05d27ad9f319e0c538e12c
parentd534bb153551a914bf00c81d02743cdbafdfc450 (diff)
downloadaur-abf907ea6ad4b2895bf2116a2878aac79c51d9eb.tar.gz
aur-abf907ea6ad4b2895bf2116a2878aac79c51d9eb.tar.xz
Hardcode urlpaths instead of getting from db
Effort to garauntee locations of known files
-rw-r--r--web/lib/pkgfuncs.inc5
1 files changed, 4 insertions, 1 deletions
diff --git a/web/lib/pkgfuncs.inc b/web/lib/pkgfuncs.inc
index 8d77b979..a323984f 100644
--- a/web/lib/pkgfuncs.inc
+++ b/web/lib/pkgfuncs.inc
@@ -1,5 +1,6 @@
<?
include_once("pkgfuncs_po.inc");
+include_once("config.inc");
# define variables used during pkgsearch
#
@@ -350,7 +351,9 @@ function package_details($id=0, $SID="") {
print "<tr>\n";
print " <td class='boxSoft' colspan='2'><span class='f3'>";
if ($row["LocationID"] == 2) {
- print "<a href='".$row['URLPath']."'>".__("Tarball")."</a> :: <a href='".dirname($row['URLPath'])."/".$row['Name']."'>".__("Files")."</a> :: <a href='".dirname($row['URLPath'])."/".$row['Name']."/PKGBUILD'>PKGBUILD</a></span></td>";
+ global $URL_DIR;
+ $urlpath = $URL_DIR.$row["Name"]."/".$row["Name"];
+ print "<a href='$urlpath.tar.gz'>".__("Tarball")."</a> :: <a href='$urlpath'>".__("Files")."</a> :: <a href='$urlpath/PKGBUILD'>PKGBUILD</a></span></td>";
} elseif ($row["LocationID"] == 3) {
print "<a href='http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/" . $row["Category"] . "/" . $row["Name"] . "/?cvsroot=AUR&only_with_tag=CURRENT'>CVS</td>";
}