summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoreliott <eliott@cactuswax.net>2007-09-24 16:57:35 +0200
committereliott <eliott@cactuswax.net>2007-09-24 16:57:35 +0200
commitaebdd21b58046f647c7c500dde5152ba774303ab (patch)
tree38472bb7a4decb86d83e31bd1be6af98ee094dbc
parentac8291a5dcbfe9edf53d627be1139fe52708d4ce (diff)
downloadaur-aebdd21b58046f647c7c500dde5152ba774303ab.tar.gz
aur-aebdd21b58046f647c7c500dde5152ba774303ab.tar.xz
More changes to page styles.
-rw-r--r--web/html/account.php7
-rw-r--r--web/html/css/arch.css20
-rw-r--r--web/html/index.php17
-rw-r--r--web/html/pkgsubmit.php8
-rw-r--r--web/lib/pkgfuncs.inc18
5 files changed, 44 insertions, 26 deletions
diff --git a/web/html/account.php b/web/html/account.php
index fd9cc617..3d981715 100644
--- a/web/html/account.php
+++ b/web/html/account.php
@@ -13,6 +13,10 @@ html_header(); # print out the HTML header
# Main page processing here
#
+echo "<div class=\"pgbox\">\n";
+echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Accounts")."</span></div>\n";
+echo " <div class=\"pgboxbody\">\n";
+
if (isset($_COOKIE["AURSID"])) {
# visitor is logged in
#
@@ -148,6 +152,9 @@ if (isset($_COOKIE["AURSID"])) {
}
}
+echo " </div>";
+echo "</div>";
+
html_footer("\$Id$");
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/css/arch.css b/web/html/css/arch.css
index 7d8f41f3..65f3cff4 100644
--- a/web/html/css/arch.css
+++ b/web/html/css/arch.css
@@ -410,7 +410,7 @@ textarea.vLargeTextField {
margin-left: 5%;
margin-right: 5%;
}
-.pkgbox {
+.pgbox {
width: 90%;
margin-left: 5%;
margin-right: 5%;
@@ -421,7 +421,17 @@ textarea.vLargeTextField {
text-align: left;
padding: 3px;
}
-.pkgboxtitle {
+.frontpgboxbody {
+ padding: 10px;
+}
+.frontpgboxbody > table {
+ width: 100%;
+}
+.boxSoftTitle {
+ text-align: right;
+}
+
+.pgboxtitle {
border-width: 2px;
border-style: solid;
border-color: #dddddd;
@@ -435,14 +445,14 @@ textarea.vLargeTextField {
padding-bottom: 2px;
padding-right: 10px;
}
-.pkgboxbody, .pkgboxbody-comment {
+.pgboxbody, .pgboxbody-comment {
padding: 10px;
}
-.pkgboxbody input {
+.pgboxbody input {
margin-right: 10px;
}
-.pkgboxbody-comment > table {
+.pgboxbody-comment > table {
border-collapse: separate;
border-spacing: 0 15px;
}
diff --git a/web/html/index.php b/web/html/index.php
index 7d28d75e..d76d13d7 100644
--- a/web/html/index.php
+++ b/web/html/index.php
@@ -79,19 +79,19 @@ if (isset($_REQUEST["user"]) || isset($_REQUEST["pass"])) {
html_header();
# Big Top Level Table (Table 1)
-print "<table border='0' cellpadding='0' cellspacing='3' width='90%'>\n";
-print "<tr>\n";
+echo "<div class=\"pgbox\">\n";
+echo " <div class=\"pgboxtitle\"><span class=\"f3\">AUR-".__("Home")."</span></div>\n";
+echo " <div class=\"frontpgboxbody\">\n";
+echo "<table border='0' cellpadding='0' cellspacing='3' width='90%'>\n";
+echo "<tr>\n";
# MAIN: Top Left
print "<td class='boxSoft' valign='top'>";
print "<p>".__("Welcome to the AUR! Please read the %hAUR User Guidelines%h and %hAUR TU Guidelines%h for more information.", array('<a href="http://wiki.archlinux.org/index.php/AUR_User_Guidelines">', '</a>', '<a href="http://wiki.archlinux.org/index.php/AUR_Trusted_User_Guidelines">', '</a>'))."<br>";
print __("Contributed PKGBUILDs <b>must</b> conform to the %hArch Packaging Standards%h otherwise they will be deleted!", array('<a href="http://wiki.archlinux.org/index.php/Arch_Packaging_Standards">', '</a>'))."</p>";
-#print "<p>".__("If you have feedback about the AUR, please leave it in %hFlyspray%h.", array('<a href="http://bugs.archlinux.org/index.php?tasks=all&amp;project=2">', '</a>'))."<br>";
-#print __("Email discussion about the AUR takes place on the %sTUR Users List%s.", array('<a href="http://www.archlinux.org/mailman/listinfo/tur-users">', '</a>'))."</p>";
print "<p>".__("Remember to vote for your favourite packages!")."<br>";
print __("The most popular packages will be provided as binary packages in [community].")."</p>";
-#print "<p>".__("Though we can't vouch for their contents, we provide a %hlist of user repositories%h for your convenience.", array('<a href="http://wiki2.archlinux.org/index.php/Unofficial%20Repositories">', '</a>'))."</p>";
# MAIN: Top Right
print "</td>";
@@ -178,9 +178,6 @@ print "</tr>";
print "</table>";
# End Table 2
-#print " <td>&nbsp;&nbsp;</td>";
-#print " <td align='left' valign='top' nowrap>\n";
-
# MAIN: Bottom Right
print "</td>";
print "<td class='boxSoft' valign='top'>";
@@ -357,8 +354,10 @@ print "</table>";
print " </td>";
print "</tr>\n";
print "</table>\n";
+echo "</div>\n";
# End Table 1
-
+echo " </div>";
+echo "</div>";
html_footer("<b>Version 1.3.1</b> \$Id$");
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 89ecfa44..24aeea5c 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -9,7 +9,9 @@ include("config.inc"); # configuration file with dir locations
set_lang(); # this sets up the visitor's language
check_sid(); # see if they're still logged in
html_header(); # print out the HTML header
-print "<center>\n";
+echo "<div class=\"pgbox\">\n";
+echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Submit")."</span></div>\n";
+echo " <div class=\"pgboxbody\">\n";
# Debugging
$DBUG = 0;
@@ -665,8 +667,8 @@ if ($_COOKIE["AURSID"]) {
print __("You must create an account before you can upload packages.");
print "<br />\n";
}
-
-print "</center>\n";
+echo " </div>\n";
+echo "</div>\n";
html_footer("\$Id$");
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/lib/pkgfuncs.inc b/web/lib/pkgfuncs.inc
index de1dc5fa..3089ccb5 100644
--- a/web/lib/pkgfuncs.inc
+++ b/web/lib/pkgfuncs.inc
@@ -269,9 +269,9 @@ function package_details($id=0, $SID="") {
# print out package details
#
- echo "<div class=\"pkgbox\">\n";
- echo " <div class=\"pkgboxtitle\"><span class=\"f3\">".__("Package Details")."</span></div>\n";
- echo " <div class=\"pkgboxbody\">\n";
+ echo "<div class=\"pgbox\">\n";
+ echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Package Details")."</span></div>\n";
+ echo " <div class=\"pgboxbody\">\n";
echo " <table>\n";
echo " <tr><td class='boxSoft' colspan='2'><span class='f2'>";
echo $row["Name"] . " " . $row["Version"]."</span></td></tr>\n";
@@ -409,9 +409,9 @@ function package_details($id=0, $SID="") {
# Actions Bar
#
if ($SID) {
- echo "<div class=\"pkgbox\">\n";
- echo " <div class=\"pkgboxtitle\"><span class=\"f3\">".__("Actions")."</span></div>\n";
- echo " <div class=\"pkgboxbody\">\n";
+ echo "<div class=\"pgbox\">\n";
+ echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Actions")."</span></div>\n";
+ echo " <div class=\"pgboxbody\">\n";
echo " <form action='/packages.php' method='post'>\n";
echo " <input type='hidden' name='IDs[".$row["ID"]."]' value='1'>\n";
echo " <input type='hidden' name='ID' value='".$row["ID"]."'>\n";
@@ -482,9 +482,9 @@ function package_details($id=0, $SID="") {
# Comments
#
- echo "<div class=\"pkgbox\">\n";
- echo " <div class=\"pkgboxtitle\"><span class=\"f3\">".__("Comments")."</span></div>\n";
- echo " <div class=\"pkgboxbody-comment\">\n";
+ echo "<div class=\"pgbox\">\n";
+ echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Comments")."</span></div>\n";
+ echo " <div class=\"pgboxbody-comment\">\n";
echo " <table width='100%'>\n";
$comments = package_comments($row["ID"]);
if (!empty($comments)) {