summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2011-02-21 17:06:47 +0100
committerLukas Fleischer <archlinux@cryptocrack.de>2011-02-21 17:07:51 +0100
commitbc207d25cd47e2ebc0a2d603f0414ca97cf94366 (patch)
treeedb6f8acc595e7a0907ece666ba208b4a7fb6595
parenta77420126b7721ebc576aef50683d8024738bbb5 (diff)
downloadaur-bc207d25cd47e2ebc0a2d603f0414ca97cf94366.tar.gz
aur-bc207d25cd47e2ebc0a2d603f0414ca97cf94366.tar.xz
Use move_uploaded_file() instead of rename() in "pkgsubmit.php".
Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
-rw-r--r--web/html/pkgsubmit.php2
1 files changed, 1 insertions, 1 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 9ef90a77..b55a7205 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -247,7 +247,7 @@ if ($_COOKIE["AURSID"]):
}
file_put_contents('PKGBUILD', $pkgbuild_raw);
- rename($_FILES['pfile']['tmp_name'], $pkg_name . '.tar.gz');
+ move_uploaded_file($_FILES['pfile']['tmp_name'], $pkg_name . '.tar.gz');
}
# Update the backend database