summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristian Klausen <kristian@klausen.dk>2021-05-09 23:51:06 +0200
committerEli Schwartz <eschwartz@archlinux.org>2021-05-10 00:06:32 +0200
commitbab74dd307f160813c1bd78cf14d3a9a092e071c (patch)
tree78d7cd05f91c75d4e80efcbef60670ed9923b761
parent8ec170b3e0ba386eb135c9a2957d983ca937c302 (diff)
downloadaur-origin/master.tar.gz
aur-origin/master.tar.xz
Update wiki links to the new short URLorigin/master
Done with: find -type f -exec sed -Ee ':wiki.archlinux.org: s:(wiki.archlinux.org)/index.php/:\1/title/:g' -i {} \; Fixes #16 [1] https://gitlab.archlinux.org/archlinux/infrastructure/-/merge_requests/335 Signed-off-by: Eli Schwartz <eschwartz@archlinux.org>
-rw-r--r--doc/sso.txt2
-rw-r--r--web/html/home.php10
-rw-r--r--web/template/pkgbase_actions.php2
3 files changed, 7 insertions, 7 deletions
diff --git a/doc/sso.txt b/doc/sso.txt
index 1b0b1f7d..481166cf 100644
--- a/doc/sso.txt
+++ b/doc/sso.txt
@@ -22,7 +22,7 @@ you may customize [options] aur_location and [sso] openid_configuration in
You may then start `keycloak.service` through systemd.
-See also ArchWiki <https://wiki.archlinux.org/index.php/Keycloak>.
+See also ArchWiki <https://wiki.archlinux.org/title/Keycloak>.
Configuring a realm
-------------------
diff --git a/web/html/home.php b/web/html/home.php
index 8fb05246..be37e970 100644
--- a/web/html/home.php
+++ b/web/html/home.php
@@ -74,9 +74,9 @@ if (isset($_COOKIE["AURSID"])) {
<?php
echo __(
'Welcome to the AUR! Please read the %sAUR User Guidelines%s and %sAUR TU Guidelines%s for more information.',
- '<a href="https://wiki.archlinux.org/index.php/AUR_User_Guidelines">',
+ '<a href="https://wiki.archlinux.org/title/AUR_User_Guidelines">',
'</a>',
- '<a href="https://wiki.archlinux.org/index.php/AUR_Trusted_User_Guidelines">',
+ '<a href="https://wiki.archlinux.org/title/AUR_Trusted_User_Guidelines">',
'</a>'
);
?>
@@ -84,7 +84,7 @@ if (isset($_COOKIE["AURSID"])) {
echo __(
'Contributed PKGBUILDs %smust%s conform to the %sArch Packaging Standards%s otherwise they will be deleted!',
'<strong>', '</strong>',
- '<a href="https://wiki.archlinux.org/index.php/Arch_Packaging_Standards">',
+ '<a href="https://wiki.archlinux.org/title/Arch_Packaging_Standards">',
'</a>'
);
?>
@@ -95,7 +95,7 @@ if (isset($_COOKIE["AURSID"])) {
<?= __('DISCLAIMER') ?>:
<?= __('AUR packages are user produced content. Any use of the provided files is at your own risk.'); ?>
</p>
- <p class="readmore"><a href="https://wiki.archlinux.org/index.php/AUR"><?= __('Learn more...') ?></a></p>
+ <p class="readmore"><a href="https://wiki.archlinux.org/title/AUR"><?= __('Learn more...') ?></a></p>
</div>
<div id="news">
<h3><a><?= __('Support') ?></a><span class="arrow"></span></h3>
@@ -131,7 +131,7 @@ if (isset($_COOKIE["AURSID"])) {
<?php
echo __(
'Git over SSH is now used to submit packages to the AUR. See the %sSubmitting packages%s section of the Arch User Repository ArchWiki page for more details.',
- '<a href="https://wiki.archlinux.org/index.php/Arch_User_Repository#Submitting_packages">',
+ '<a href="https://wiki.archlinux.org/title/Arch_User_Repository#Submitting_packages">',
'</a>'
);
?>
diff --git a/web/template/pkgbase_actions.php b/web/template/pkgbase_actions.php
index 5eee5478..3d208328 100644
--- a/web/template/pkgbase_actions.php
+++ b/web/template/pkgbase_actions.php
@@ -7,7 +7,7 @@
<a href="<?= $log_uri ?>"><?= __('View Changes') ?></a>
</li>
<li><a href="<?= $snapshot_uri ?>"><?= __('Download snapshot') ?></a>
- <li><a href="https://wiki.archlinux.org/index.php/Special:Search?search=<?= urlencode($row['Name']) ?>"><?= __('Search wiki') ?></a></li>
+ <li><a href="https://wiki.archlinux.org/title/Special:Search?search=<?= urlencode($row['Name']) ?>"><?= __('Search wiki') ?></a></li>
<li><span class="flagged"><?= $row["OutOfDateTS"] !== NULL ? html_action_link($base_uri . 'flag-comment/', __('Flagged out-of-date (%s)', "$out_of_date_time")) : "" ?></span></li>
<?php if ($row["OutOfDateTS"] === NULL): ?>
<li><?= html_action_link($base_uri . 'flag/', __('Flag package out-of-date')) ?></li>