summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Morris <kevr@0cost.org>2021-01-20 23:08:39 +0100
committerLukas Fleischer <lfleischer@archlinux.org>2021-02-20 17:52:53 +0100
commitf6cbb433efd89090764921a74da490427e268118 (patch)
tree986181a18f16627a3ffd7be19d1403e61dd0aed9
parenta376020977085d08a49d427e6bf7c4266a7f6413 (diff)
downloadaur-f6cbb433efd89090764921a74da490427e268118.tar.gz
aur-f6cbb433efd89090764921a74da490427e268118.tar.xz
install aurweb package & init db on GitLab CI
Signed-off-by: Kevin Morris <kevr@0cost.org>
-rw-r--r--.gitlab-ci.yml3
1 files changed, 3 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 71c14457..6db573d2 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -18,5 +18,8 @@ before_script:
test:
script:
+ - python setup.py install
+ - sed -r "s;YOUR_AUR_ROOT;$(pwd);g" conf/config.dev > conf/config
+ - AUR_CONFIG=conf/config python -m aurweb.initdb
- make -C test
- coverage report --include='aurweb/*'