summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2012-09-21 10:42:17 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2012-09-24 12:23:05 +0200
commitd56a88897bcaa9d552d1d2b90c33b7c6e29e330a (patch)
treec497cc2c86ca4592496d16223ce4e231e5f44e6e
parent6102759b7cb9fd23f4e7fa5f12137334ff30a410 (diff)
downloadaur-d56a88897bcaa9d552d1d2b90c33b7c6e29e330a.tar.gz
aur-d56a88897bcaa9d552d1d2b90c33b7c6e29e330a.tar.xz
Avoid use of "<b>"/"</b>"
* Use "<label>"/"</label>" for form labels. * Use "<strong>"/"</strong>" for important text. * Use "<h4>"/"</h4>" for headings. * Drop "<b>"/"</b>" everywhere else. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
-rw-r--r--web/html/addvote.php12
-rw-r--r--web/html/home.php5
-rw-r--r--web/html/pkgsubmit.php2
-rw-r--r--web/lib/acctfuncs.inc.php12
-rw-r--r--web/lib/feedcreator.class.php2
-rw-r--r--web/lib/translator.inc.php2
-rw-r--r--web/template/tu_details.php8
7 files changed, 21 insertions, 22 deletions
diff --git a/web/html/addvote.php b/web/html/addvote.php
index 55750317..43973f32 100644
--- a/web/html/addvote.php
+++ b/web/html/addvote.php
@@ -70,18 +70,18 @@ if ($atype == "Trusted User" || $atype == "Developer") {
<form action="<?= get_uri('/addvote/'); ?>" method="post">
<p>
- <b><?= __("Applicant/TU") ?></b>
- <input type="text" name="user" value="<?php if (!empty($_POST['user'])) { print htmlentities($_POST['user'], ENT_QUOTES); } ?>" />
+ <label for="id_user"><?= __("Applicant/TU") ?></label>
+ <input type="text" name="user" id="id_user" value="<?php if (!empty($_POST['user'])) { print htmlentities($_POST['user'], ENT_QUOTES); } ?>" />
<?= __("(empty if not applicable)") ?>
</p>
<p>
- <b><?= __("Length in days") ?></b>
- <input type="text" name="length" value="<?php if (!empty($_POST['length'])) { print htmlentities($_POST['length'], ENT_QUOTES); } ?>" />
+ <label for="id_length"><?= __("Length in days") ?></label>
+ <input type="text" name="length" id="id_length" value="<?php if (!empty($_POST['length'])) { print htmlentities($_POST['length'], ENT_QUOTES); } ?>" />
<?= __("(defaults to 7 if empty)") ?>
</p>
<p>
- <b><?= __("Proposal") ?></b><br />
- <textarea name="agenda" rows="15" cols="80"><?php if (!empty($_POST['agenda'])) { print htmlentities($_POST['agenda']); } ?></textarea><br />
+ <label for="id_agenda"><?= __("Proposal") ?></label><br />
+ <textarea name="agenda" id="id_agenda" rows="15" cols="80"><?php if (!empty($_POST['agenda'])) { print htmlentities($_POST['agenda']); } ?></textarea><br />
<input type="hidden" name="addVote" value="1" />
<input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
<input type="submit" class="button" value="<?= __("Submit"); ?>" />
diff --git a/web/html/home.php b/web/html/home.php
index 3050bd10..f5a9afe9 100644
--- a/web/html/home.php
+++ b/web/html/home.php
@@ -33,7 +33,7 @@ $dbh = db_connect();
<?php
echo __(
'Contributed PKGBUILDs %smust%s conform to the %sArch Packaging Standards%s otherwise they will be deleted!',
- '<b>', '</b>',
+ '<strong>', '</strong>',
'<a href="http://wiki.archlinux.org/index.php/Arch_Packaging_Standards">',
'</a>'
);
@@ -67,9 +67,8 @@ $dbh = db_connect();
?>
</p>
+ <h4><?= __('DISCLAIMER') ?></h4>
<div class="important">
- <b><?= __('DISCLAIMER') ?> :</b>
- <br />
<?= __('Unsupported packages are user produced content. Any use of the provided files is at your own risk.'); ?>
</div>
</div>
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index ffbc1c95..930add05 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -324,7 +324,7 @@ if ($uid):
$error = __( "Could not create directory %s.", $incoming_pkgdir);
}
} else {
- $error = __( "You are not allowed to overwrite the %s%s%s package.", "<b>", $pkg_name, "</b>");
+ $error = __( "You are not allowed to overwrite the %s%s%s package.", "<strong>", $pkg_name, "</strong>");
}
if (!$error) {
diff --git a/web/lib/acctfuncs.inc.php b/web/lib/acctfuncs.inc.php
index 44cbfbd8..bce00f86 100644
--- a/web/lib/acctfuncs.inc.php
+++ b/web/lib/acctfuncs.inc.php
@@ -165,7 +165,7 @@ function process_account_form($UTYPE,$TYPE,$A,$U="",$T="",$S="",$E="",
if ($row[0]) {
$error = __("The username, %s%s%s, is already in use.",
- "<b>", htmlspecialchars($U,ENT_QUOTES), "</b>");
+ "<strong>", htmlspecialchars($U,ENT_QUOTES), "</strong>");
}
}
if (!$error) {
@@ -182,7 +182,7 @@ function process_account_form($UTYPE,$TYPE,$A,$U="",$T="",$S="",$E="",
if ($row[0]) {
$error = __("The address, %s%s%s, is already in use.",
- "<b>", htmlspecialchars($E,ENT_QUOTES), "</b>");
+ "<strong>", htmlspecialchars($E,ENT_QUOTES), "</strong>");
}
}
if ($error) {
@@ -209,12 +209,12 @@ function process_account_form($UTYPE,$TYPE,$A,$U="",$T="",$S="",$E="",
$result = $dbh->exec($q);
if (!$result) {
print __("Error trying to create account, %s%s%s.",
- "<b>", htmlspecialchars($U,ENT_QUOTES), "</b>");
+ "<strong>", htmlspecialchars($U,ENT_QUOTES), "</strong>");
} else {
# account created/modified, tell them so.
#
print __("The account, %s%s%s, has been successfully created.",
- "<b>", htmlspecialchars($U,ENT_QUOTES), "</b>");
+ "<strong>", htmlspecialchars($U,ENT_QUOTES), "</strong>");
print "<p>\n";
print __("Click on the Login link above to use your account.");
print "</p>\n";
@@ -247,10 +247,10 @@ function process_account_form($UTYPE,$TYPE,$A,$U="",$T="",$S="",$E="",
$result = $dbh->exec($q);
if (!$result) {
print __("Error trying to modify account, %s%s%s.",
- "<b>", htmlspecialchars($U,ENT_QUOTES), "</b>");
+ "<strong>", htmlspecialchars($U,ENT_QUOTES), "</strong>");
} else {
print __("The account, %s%s%s, has been successfully modified.",
- "<b>", htmlspecialchars($U,ENT_QUOTES), "</b>");
+ "<strong>", htmlspecialchars($U,ENT_QUOTES), "</strong>");
}
}
}
diff --git a/web/lib/feedcreator.class.php b/web/lib/feedcreator.class.php
index 1d57fac4..802eebbe 100644
--- a/web/lib/feedcreator.class.php
+++ b/web/lib/feedcreator.class.php
@@ -689,7 +689,7 @@ class FeedCreator extends HtmlDescribable {
$this->_redirect($filename);
}
} else {
- echo "<br /><b>Error creating feed file, please check write permissions.</b><br />";
+ echo "<br /><strong>Error creating feed file, please check write permissions.</strong><br />";
}
}
diff --git a/web/lib/translator.inc.php b/web/lib/translator.inc.php
index 382160cc..2093cf79 100644
--- a/web/lib/translator.inc.php
+++ b/web/lib/translator.inc.php
@@ -9,7 +9,7 @@ set_include_path(get_include_path() . PATH_SEPARATOR . '../lib' . PATH_SEPARATOR
#
# examples:
# print __("%s has %s apples.", "Bill", "5");
-# print __("This is a %smajor%s problem!", "<b>", "</b>");
+# print __("This is a %smajor%s problem!", "<strong>", "</strong>");
include_once('config.inc.php');
include_once('gettext.php');
diff --git a/web/template/tu_details.php b/web/template/tu_details.php
index 035cc8d7..b53797f0 100644
--- a/web/template/tu_details.php
+++ b/web/template/tu_details.php
@@ -9,18 +9,18 @@
<p>
<?= __("User") ?>:
- <b>
+ <strong>
<?php if (!empty($row['User'])): ?>
<a href="<?= get_uri('/packages/'); ?>?K=<?= $row['User'] ?>&amp;SeB=m"><?= $row['User'] ?></a>
<?php else: ?>
N/A
<?php endif; ?>
- </b>
+ </strong>
<br />
- <?= __("Submitted: %s by %s", "<b>" . gmdate("Y-m-d H:i", $row['Submitted']) . "</b>", "<b>" . username_from_id($row['SubmitterID']) . "</b>") ?>
+ <?= __("Submitted: %s by %s", gmdate("Y-m-d H:i", $row['Submitted']), username_from_id($row['SubmitterID'])) ?>
<br />
<?= __("End") ?>:
- <b><?= gmdate("Y-m-d H:i", $row['End']) ?></b>
+ <strong><?= gmdate("Y-m-d H:i", $row['End']) ?></strong>
</p>
<p>