diff options
author | Frédéric Mangano-Tarumi <fmang@mg0.fr> | 2020-02-16 21:56:10 +0100 |
---|---|---|
committer | Lukas Fleischer <lfleischer@archlinux.org> | 2020-02-27 16:44:36 +0100 |
commit | 7188743fc3b1a9c1f5f65e323a6502d018bd95d5 (patch) | |
tree | d313ae39015fd5b664206048a946f420aecc7775 /INSTALL | |
parent | 4b2102ceb26b77bc8ee3e9b9d8929a915f1e65a9 (diff) | |
download | aur-7188743fc3b1a9c1f5f65e323a6502d018bd95d5.tar.gz aur-7188743fc3b1a9c1f5f65e323a6502d018bd95d5.tar.xz |
Migrate the database schema to SQLAlchemy
The new schema was generated with sqlacodegen and then manually adjusted
to fit schema/aur-schema.sql faithfully, both in the organisation of the
code and in the SQL generated by SQLAlchemy.
Initializing the database now requires the new tool aurweb.initdb.
References to aur-schema.sql have been updated and the old schema
dropped.
Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'INSTALL')
-rw-r--r-- | INSTALL | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -45,16 +45,16 @@ read the instructions below. if the defaults file does not exist) and adjust the configuration (pay attention to disable_http_login, enable_maintenance and aur_location). -4) Create a new MySQL database and a user and import the aurweb SQL schema: +4) Install Python modules and dependencies: - $ mysql -uaur -p AUR </srv/http/aurweb/schema/aur-schema.sql - -5) Install Python modules and dependencies: - - # pacman -S python-mysql-connector python-pygit2 python-srcinfo + # pacman -S python-mysql-connector python-pygit2 python-srcinfo python-sqlalchemy # pacman -S python-bleach python-markdown # python3 setup.py install +5) Create a new MySQL database and a user and import the aurweb SQL schema: + + $ python -m aurweb.initdb + 6) Create a new user: # useradd -U -d /srv/http/aurweb -c 'AUR user' aur |