summaryrefslogtreecommitdiffstats
path: root/INSTALL
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:19:11 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:25:43 +0200
commitd4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2 (patch)
tree509f59c92a2a555a1e743f0ea689c5766c36319a /INSTALL
parente182ba0c42a9d2b2afecb8da32d00f634999935e (diff)
downloadaur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.gz
aur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.xz
Reorganize Git interface scripts
Move the Git interface scripts from git-interface/ to aurweb/git/. Use setuptools to automatically create wrappers which can be installed using `python3 setup.py install`. Update the configuration files, the test suite as well as the INSTALL and README files to reflect these changes. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'INSTALL')
-rw-r--r--INSTALL28
1 files changed, 12 insertions, 16 deletions
diff --git a/INSTALL b/INSTALL
index dab48cc1..395915ae 100644
--- a/INSTALL
+++ b/INSTALL
@@ -37,11 +37,16 @@ Setup on Arch Linux
$ mysql -uaur -p AUR </srv/http/aurweb/schema/aur-schema.sql
-5) Create a new user:
+5) Install Python modules and dependencies:
+
+ # pacman -S python-mysql-connector python-pygit2 python-srcinfo
+ # python3 setup.py install
+
+6) Create a new user:
# useradd -U -d /srv/http/aurweb -c 'AUR user' aur
-6) Initialize the Git repository:
+7) Initialize the Git repository:
# mkdir /srv/http/aurweb/aur.git/
# cd /srv/http/aurweb/aur.git/
@@ -49,29 +54,20 @@ Setup on Arch Linux
# git config --local transfer.hideRefs '^refs/'
# git config --local --add transfer.hideRefs '!refs/'
# git config --local --add transfer.hideRefs '!HEAD'
- # ln -s ../../git-interface/git-update.py hooks/update
+ # ln -s /usr/local/bin/aurweb-git-update hooks/update
# chown -R aur .
-7) Install needed Python modules:
-
- # pacman -S python-mysql-connector python-pygit2 python-srcinfo
-
-8) Install the git-auth wrapper script:
-
- # cd /srv/http/aurweb/git-interface/
- # make && make install
-
-9) Configure sshd(8) for the AUR. Add the following lines at the end of your
+8) Configure sshd(8) for the AUR. Add the following lines at the end of your
sshd_config(5) and restart the sshd. Note that OpenSSH 6.9 or newer is
needed!
Match User aur
PasswordAuthentication no
- AuthorizedKeysCommand /usr/local/bin/aur-git-auth "%t" "%k"
+ AuthorizedKeysCommand /usr/local/bin/aurweb-git-auth "%t" "%k"
AuthorizedKeysCommandUser aur
-10) If you want to enable smart HTTP support with nginx and fcgiwrap, you can
- use the following directives:
+9) If you want to enable smart HTTP support with nginx and fcgiwrap, you can
+ use the following directives:
location ~ "^/([a-z0-9][a-z0-9.+_-]*?)(\.git)?/(git-(receive|upload)-pack|HEAD|info/refs|objects/(info/(http-)?alternates|packs)|[0-9a-f]{2}/[0-9a-f]{38}|pack/pack-[0-9a-f]{40}\.(pack|idx))$" {
fastcgi_pass unix:/run/fcgiwrap.sock;