summaryrefslogtreecommitdiffstats
path: root/git-interface/Makefile
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:19:11 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:25:43 +0200
commitd4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2 (patch)
tree509f59c92a2a555a1e743f0ea689c5766c36319a /git-interface/Makefile
parente182ba0c42a9d2b2afecb8da32d00f634999935e (diff)
downloadaur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.gz
aur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.xz
Reorganize Git interface scripts
Move the Git interface scripts from git-interface/ to aurweb/git/. Use setuptools to automatically create wrappers which can be installed using `python3 setup.py install`. Update the configuration files, the test suite as well as the INSTALL and README files to reflect these changes. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'git-interface/Makefile')
-rw-r--r--git-interface/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/git-interface/Makefile b/git-interface/Makefile
deleted file mode 100644
index 88657904..00000000
--- a/git-interface/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-GIT_INTERFACE_DIR := $(abspath $(dir $(lastword $(MAKEFILE_LIST))))
-
-include config.mk
-
-git-auth.sh:
- sed 's#%GIT_INTERFACE_DIR%#$(GIT_INTERFACE_DIR)#' <git-auth.sh.in >git-auth.sh
- chmod +x git-auth.sh
-
-install: git-auth.sh
- install -Dm0755 git-auth.sh "$(DESTDIR)$(PREFIX)/bin/aur-git-auth"
-
-uninstall:
- rm -f "$(DESTDIR)$(PREFIX)/bin/aur-git-auth"
-
-clean:
- rm -f git-auth.sh
-
-.PHONY: install uninstall clean