summaryrefslogtreecommitdiffstats
path: root/git-interface/git-auth.py
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:19:11 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:25:43 +0200
commitd4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2 (patch)
tree509f59c92a2a555a1e743f0ea689c5766c36319a /git-interface/git-auth.py
parente182ba0c42a9d2b2afecb8da32d00f634999935e (diff)
downloadaur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.gz
aur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.xz
Reorganize Git interface scripts
Move the Git interface scripts from git-interface/ to aurweb/git/. Use setuptools to automatically create wrappers which can be installed using `python3 setup.py install`. Update the configuration files, the test suite as well as the INSTALL and README files to reflect these changes. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'git-interface/git-auth.py')
-rwxr-xr-xgit-interface/git-auth.py62
1 files changed, 0 insertions, 62 deletions
diff --git a/git-interface/git-auth.py b/git-interface/git-auth.py
deleted file mode 100755
index 022b0fff..00000000
--- a/git-interface/git-auth.py
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/usr/bin/python3
-
-import shlex
-import re
-import sys
-
-import aurweb.config
-import aurweb.db
-
-
-def format_command(env_vars, command, ssh_opts, ssh_key):
- environment = ''
- for key, var in env_vars.items():
- environment += '{}={} '.format(key, shlex.quote(var))
-
- command = shlex.quote(command)
- command = '{}{}'.format(environment, command)
-
- # The command is being substituted into an authorized_keys line below,
- # so we need to escape the double quotes.
- command = command.replace('"', '\\"')
- msg = 'command="{}",{} {}'.format(command, ssh_opts, ssh_key)
- return msg
-
-
-def main():
- valid_keytypes = aurweb.config.get('auth', 'valid-keytypes').split()
- username_regex = aurweb.config.get('auth', 'username-regex')
- git_serve_cmd = aurweb.config.get('auth', 'git-serve-cmd')
- ssh_opts = aurweb.config.get('auth', 'ssh-options')
-
- keytype = sys.argv[1]
- keytext = sys.argv[2]
- if keytype not in valid_keytypes:
- exit(1)
-
- conn = aurweb.db.Connection()
-
- cur = conn.execute("SELECT Users.Username, Users.AccountTypeID FROM Users "
- "INNER JOIN SSHPubKeys ON SSHPubKeys.UserID = Users.ID "
- "WHERE SSHPubKeys.PubKey = ? AND Users.Suspended = 0",
- (keytype + " " + keytext,))
-
- row = cur.fetchone()
- if not row or cur.fetchone():
- exit(1)
-
- user, account_type = row
- if not re.match(username_regex, user):
- exit(1)
-
- env_vars = {
- 'AUR_USER': user,
- 'AUR_PRIVILEGED': '1' if account_type > 1 else '0',
- }
- key = keytype + ' ' + keytext
-
- print(format_command(env_vars, git_serve_cmd, ssh_opts, key))
-
-
-if __name__ == '__main__':
- main()