summaryrefslogtreecommitdiffstats
path: root/git-interface/test/Makefile
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2016-08-04 20:36:31 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2016-08-05 12:12:09 +0200
commit6e38309c194d860cccd26f901ee5687502331779 (patch)
tree53b70a6444cbe07e60466b7cd4783a7879b8653a /git-interface/test/Makefile
parent5014b74868138172090e7528f1b069642e15f295 (diff)
downloadaur-6e38309c194d860cccd26f901ee5687502331779.tar.gz
aur-6e38309c194d860cccd26f901ee5687502331779.tar.xz
git-interface: Add test suite and basic tests
Add basic tests for the Git interface. The test suite is based on sharness. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'git-interface/test/Makefile')
-rw-r--r--git-interface/test/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/git-interface/test/Makefile b/git-interface/test/Makefile
new file mode 100644
index 00000000..d6f0f740
--- /dev/null
+++ b/git-interface/test/Makefile
@@ -0,0 +1,11 @@
+T = $(sort $(wildcard t[0-9][0-9][0-9][0-9]-*.sh))
+
+check: $(T)
+
+clean:
+ $(RM) -r test-results/
+
+$(T):
+ @echo "*** $@ ***"; $(SHELL) $@
+
+.PHONY: check clean $(T)