summaryrefslogtreecommitdiffstats
path: root/po
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2018-07-07 16:04:39 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2018-07-07 16:05:12 +0200
commit840ee20f7b9327fd5e3445af2652b299fdd0ff7f (patch)
tree69a4a2000a25d04e2d719f64c3fd1cbe655a9611 /po
parent41a4189d2078e1571d784068e34e7a753bcb8f22 (diff)
downloadaur-840ee20f7b9327fd5e3445af2652b299fdd0ff7f.tar.gz
aur-840ee20f7b9327fd5e3445af2652b299fdd0ff7f.tar.xz
Rename translation resources from aur to aurweb
* Rename the aur project to aurweb on Transifex. * Rename aur.pot to aurweb.pot. * Update documentation and Makefile. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'po')
-rw-r--r--po/Makefile16
-rw-r--r--po/aurweb.pot (renamed from po/aur.pot)0
2 files changed, 8 insertions, 8 deletions
diff --git a/po/Makefile b/po/Makefile
index 78073f86..57fa9f77 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -44,9 +44,9 @@ all: ${MOFILES}
%.mo: %.po
msgfmt --check -o $@ $<
-%.po-update: %.po aur.pot
+%.po-update: %.po aurweb.pot
lang=`echo $@ | sed -e 's/\.po-update$$//'`; \
- msgmerge -U --no-location --lang="$$lang" $< aur.pot
+ msgmerge -U --no-location --lang="$$lang" $< aurweb.pot
POTFILES-php:
find ../web -type f -name '*.php' -printf '%P\n' | sort >POTFILES-php
@@ -55,19 +55,19 @@ POTFILES-py:
find ../aurweb -type f -name '*.py' -printf '%P\n' | sort >POTFILES-py
update-pot: POTFILES-php POTFILES-py
- pkgname=AUR; \
+ pkgname=AURWEB; \
pkgver=`sed -n 's/.*"AURWEB_VERSION", "\(.*\)".*/\1/p' ../web/lib/version.inc.php`; \
- xgettext --default-domain=aur -L php --keyword=__ --keyword=_n:1,2 \
+ xgettext --default-domain=aurweb -L php --keyword=__ --keyword=_n:1,2 \
--add-location=file --add-comments=TRANSLATORS: \
--package-name="$$pkgname" --package-version="$$pkgver" \
--msgid-bugs-address='${MSGID_BUGS_ADDRESS}' \
- --directory ../web --files-from POTFILES-php -o aur.pot; \
- xgettext --default-domain=aur -L python --join-existing \
+ --directory ../web --files-from POTFILES-php -o aurweb.pot; \
+ xgettext --default-domain=aurweb -L python --join-existing \
--keyword=translate \
--add-location=file --add-comments=TRANSLATORS: \
--package-name="$$pkgname" --package-version="$$pkgver" \
--msgid-bugs-address='${MSGID_BUGS_ADDRESS}' \
- --directory ../aurweb --files-from POTFILES-py -o aur.pot
+ --directory ../aurweb --files-from POTFILES-py -o aurweb.pot
update-po:
${MAKE} ${UPDATEPOFILES}
@@ -77,7 +77,7 @@ clean:
install: all
for l in ${LOCALES}; do mkdir -p ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/; done
- for l in ${LOCALES}; do cp $$l.mo ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/aur.mo; done
+ for l in ${LOCALES}; do cp $$l.mo ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/aurweb.mo; done
uninstall:
for l in ${LOCALES}; do rm -rf ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/; done
diff --git a/po/aur.pot b/po/aurweb.pot
index e49dc132..e49dc132 100644
--- a/po/aur.pot
+++ b/po/aurweb.pot