summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2017-04-23 12:46:48 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2017-04-23 18:43:26 +0200
commit016b40f99d679f0787f7c8a5f61f4a411b6c3632 (patch)
tree587e6326208d2b241a4f719e6db55b765b92df4b /setup.py
parent4abde895a5b579fb798e062806c8fef2289f0d8f (diff)
downloadaur-016b40f99d679f0787f7c8a5f61f4a411b6c3632.tar.gz
aur-016b40f99d679f0787f7c8a5f61f4a411b6c3632.tar.xz
Render comments when storing them in the database
Instead of converting package comments from plain text to HTML code when they are displayed, do the conversion when the comment is posted and store the rendered result in the database. The conversion itself is done by a Python script which uses Bleach for sanitizing the text. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 99dbfedf..9d10cc1c 100644
--- a/setup.py
+++ b/setup.py
@@ -27,6 +27,7 @@ setup(
'aurweb-notify = aurweb.scripts.notify:main',
'aurweb-pkgmaint = aurweb.scripts.pkgmaint:main',
'aurweb-popupdate = aurweb.scripts.popupdate:main',
+ 'aurweb-rendercomment = aurweb.scripts.rendercomment:main',
'aurweb-tuvotereminder = aurweb.scripts.tuvotereminder:main',
],
},