summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:19:11 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:25:43 +0200
commitd4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2 (patch)
tree509f59c92a2a555a1e743f0ea689c5766c36319a /setup.py
parente182ba0c42a9d2b2afecb8da32d00f634999935e (diff)
downloadaur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.gz
aur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.xz
Reorganize Git interface scripts
Move the Git interface scripts from git-interface/ to aurweb/git/. Use setuptools to automatically create wrappers which can be installed using `python3 setup.py install`. Update the configuration files, the test suite as well as the INSTALL and README files to reflect these changes. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 48eb1769..b64e71cb 100644
--- a/setup.py
+++ b/setup.py
@@ -17,4 +17,11 @@ setup(
name="aurweb",
version=version,
packages=find_packages(),
+ entry_points={
+ 'console_scripts': [
+ 'aurweb-git-auth = aurweb.git.auth:main',
+ 'aurweb-git-serve = aurweb.git.serve:main',
+ 'aurweb-git-update = aurweb.git.update:main',
+ ],
+ },
)