summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2017-03-01 20:12:57 +0100
committerLukas Fleischer <lfleischer@archlinux.org>2017-03-01 20:12:57 +0100
commitda4bd3b59efe63899e2271980cf1c7751b9fa6dc (patch)
treecc47c10c1648745ba80296f98505b886105047a2 /test/Makefile
parent48f28375255a2614269e4c6c38ecd6c61fe44cfd (diff)
downloadaur-da4bd3b59efe63899e2271980cf1c7751b9fa6dc.tar.gz
aur-da4bd3b59efe63899e2271980cf1c7751b9fa6dc.tar.xz
Add a Makefile to build an SQLite-compatible schema
Allow for automatically converting the schema into a schema that works with SQLite by running `make` from the schema/ subdirectory. Use the new Makefile in the test suite. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/Makefile b/test/Makefile
index d6f0f740..4ce9b9be 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,6 +1,10 @@
+FOREIGN_TARGETS = ../schema/aur-schema-sqlite.sql
T = $(sort $(wildcard t[0-9][0-9][0-9][0-9]-*.sh))
-check: $(T)
+check: $(FOREIGN_TARGETS) $(T)
+
+$(FOREIGN_TARGETS):
+ $(MAKE) -C $(dir $@) $(notdir $@)
clean:
$(RM) -r test-results/
@@ -8,4 +12,4 @@ clean:
$(T):
@echo "*** $@ ***"; $(SHELL) $@
-.PHONY: check clean $(T)
+.PHONY: check $(FOREIGN_TARGETS) clean $(T)