summaryrefslogtreecommitdiffstats
path: root/test
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi <fmang@mg0.fr>2020-02-16 21:56:10 +0100
committerLukas Fleischer <lfleischer@archlinux.org>2020-02-27 16:44:36 +0100
commit7188743fc3b1a9c1f5f65e323a6502d018bd95d5 (patch)
treed313ae39015fd5b664206048a946f420aecc7775 /test
parent4b2102ceb26b77bc8ee3e9b9d8929a915f1e65a9 (diff)
downloadaur-7188743fc3b1a9c1f5f65e323a6502d018bd95d5.tar.gz
aur-7188743fc3b1a9c1f5f65e323a6502d018bd95d5.tar.xz
Migrate the database schema to SQLAlchemy
The new schema was generated with sqlacodegen and then manually adjusted to fit schema/aur-schema.sql faithfully, both in the organisation of the code and in the SQL generated by SQLAlchemy. Initializing the database now requires the new tool aurweb.initdb. References to aur-schema.sql have been updated and the old schema dropped. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'test')
-rw-r--r--test/Makefile6
-rw-r--r--test/setup.sh5
2 files changed, 2 insertions, 9 deletions
diff --git a/test/Makefile b/test/Makefile
index 4ce9b9be..f559e169 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,10 +1,6 @@
-FOREIGN_TARGETS = ../schema/aur-schema-sqlite.sql
T = $(sort $(wildcard t[0-9][0-9][0-9][0-9]-*.sh))
-check: $(FOREIGN_TARGETS) $(T)
-
-$(FOREIGN_TARGETS):
- $(MAKE) -C $(dir $@) $(notdir $@)
+check: $(T)
clean:
$(RM) -r test-results/
diff --git a/test/setup.sh b/test/setup.sh
index 5c761f22..12f6edcc 100644
--- a/test/setup.sh
+++ b/test/setup.sh
@@ -110,10 +110,7 @@ SSH_TTY=/dev/pts/0
export SSH_CLIENT SSH_CONNECTION SSH_TTY
# Initialize the test database.
-DBSCHEMA="$TOPLEVEL/schema/aur-schema-sqlite.sql"
-[ -f "$DBSCHEMA" ] || error 'SQLite database schema not found'
-rm -f aur.db
-sqlite3 aur.db <"$DBSCHEMA"
+python -m aurweb.initdb
echo "INSERT INTO Users (ID, UserName, Passwd, Email, LangPreference, AccountTypeID) VALUES (1, 'user', '!', 'user@localhost', 'en', 1);" | sqlite3 aur.db
echo "INSERT INTO Users (ID, UserName, Passwd, Email, LangPreference, AccountTypeID) VALUES (2, 'tu', '!', 'tu@localhost', 'en', 2);" | sqlite3 aur.db