summaryrefslogtreecommitdiffstats
path: root/web/html/index.php
diff options
context:
space:
mode:
authoreliott <eliott@cactuswax.net>2007-11-17 09:01:58 +0100
committerDan McGee <dan@archlinux.org>2008-01-20 07:21:18 +0100
commita9837329d697a9e18401309a1496cc3b5015bc6a (patch)
tree30bd36b85241d923958b242839de0f8202856042 /web/html/index.php
parent6dbe12264ac0998ac4b69a507c0b7c1b55c03c1f (diff)
downloadaur-a9837329d697a9e18401309a1496cc3b5015bc6a.tar.gz
aur-a9837329d697a9e18401309a1496cc3b5015bc6a.tar.xz
Hand diff of simo's patch to remove flag safe functionality.
Simo's original commit text: The idea of safe flagging is unclear, poorly named, misunderstood, and not even used. At the time this patch was created, less than a third of the packages in unsupported were flagged safe, and less than a tenth of users knew how to interpret it. The safe flag has been replaced by a disclaimer on the main page.
Diffstat (limited to 'web/html/index.php')
-rw-r--r--web/html/index.php37
1 files changed, 1 insertions, 36 deletions
diff --git a/web/html/index.php b/web/html/index.php
index b379d4d1..854c32c0 100644
--- a/web/html/index.php
+++ b/web/html/index.php
@@ -210,11 +210,6 @@ $result = db_query($q, $dbh);
$row = mysql_fetch_row($result);
$update_count = $row[0];
-$q = "SELECT count(*) FROM Packages,PackageLocations WHERE Packages.LocationID = PackageLocations.ID AND PackageLocations.Location = 'unsupported' AND Packages.Safe = 1";
-$result = db_query($q, $dbh);
-$row = mysql_fetch_row($result);
-$safe_count = $row[0];
-
# Added the user statistcs.
# Added by: dsa <dsandrade@gmail.com>
$user = username_from_sid($_COOKIE["AURSID"]);
@@ -270,30 +265,6 @@ if (!empty($user)) {
print "</td>";
print "<td class='boxSoft'><span class='f4'>$flagged_outdated</span></td>";
print "</tr>";
-
- # Number of safe packages
- print "<tr>";
- print "<td class='boxSoft'>";
- if ($atype == 'Trusted User' || $atype == 'Developer') {
- $q = "SELECT count(*) FROM Packages,Users WHERE Packages.Safe = 1 AND Packages.VerifiedBy = Users.ID AND Users.Username='".mysql_real_escape_string($user)."'";
- $result = db_query($q, $dbh);
- $row = mysql_fetch_row($result);
- $flagged_safe = $row[0];
-
- print "<span class='f4'>".__("Flagged as safe by me")."</span>";
- }
- else
- {
- $q = "SELECT count(*) FROM Packages,Users WHERE Packages.Safe = 1 AND Packages.MaintainerUID = Users.ID AND Users.Username='".mysql_real_escape_string($user)."'";
- $result = db_query($q, $dbh);
- $row = mysql_fetch_row($result);
- $flagged_safe = $row[0];
-
- print "<span class='f4'>".__("Flagged as safe")."</span>";
- }
- print "</td>";
- print "<td class='boxSoft'><span class='f4'>$flagged_safe</span></td>";
- print "</tr>";
print "</table><br />";
}
@@ -315,13 +286,6 @@ print "</tr>";
print "<tr>";
print "<td class='boxSoft'>";
-print "<span class='f4'>".__("Packages in unsupported and flagged as safe")."</span>";
-print "</td>";
-print "<td class='boxSoft'><span class='f4'>$safe_count</span></td>";
-print "</tr>";
-
-print "<tr>";
-print "<td class='boxSoft'>";
print "<span class='f4'>".__("Packages in [community]")."</span>";
print "</td>";
print "<td class='boxSoft'><span class='f4'>$community_count</span></td>";
@@ -356,6 +320,7 @@ print "</tr>\n";
print "</table>\n";
echo "</div>\n";
# End Table 1
+echo "<span class='f4'>".__("DISCLAIMER: Unsupported PKGBUILDs are user produced content, by downloading them you agree to do so at your own risk.")."</span>";
echo " </div>";
echo "</div>";
html_footer(AUR_VERSION);