summaryrefslogtreecommitdiffstats
path: root/web/html/pkgsubmit.php
diff options
context:
space:
mode:
authordsa <dsa>2007-03-05 05:07:46 +0100
committerdsa <dsa>2007-03-05 05:07:46 +0100
commit18cfe569e0368cee80c1eb5783be97d7446f55e0 (patch)
treef4368e46e56c857ff950490217822656c5af2e4f /web/html/pkgsubmit.php
parent5e32d69d99c0ce0ee000c84100f1d8cd78cce31e (diff)
downloadaur-18cfe569e0368cee80c1eb5783be97d7446f55e0.tar.gz
aur-18cfe569e0368cee80c1eb5783be97d7446f55e0.tar.xz
Added support for uploading files with '+' characters.
Diffstat (limited to 'web/html/pkgsubmit.php')
-rw-r--r--web/html/pkgsubmit.php4
1 files changed, 2 insertions, 2 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 5b2efd70..4faa8fde 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -36,8 +36,8 @@ if ($_COOKIE["AURSID"]) {
# Solves the problem when you try to submit PKGBUILD
# that have the name with a period like (gstreamer0.10)
- # Added by: dsa <dsandrade@gmail.com>
- $presult = preg_match("/^[a-z0-9][a-z0-9\._-]*$/", $pkg_name);
+ # Added support for packages with + characters like (mysql++).
+ $presult = preg_match("/^[a-z0-9][a-z0-9\.+_-]*$/", $pkg_name);
if ($presult == FALSE || $presult <= 0) {
# FALSE => error processing regex, 0 => invalid characters