summaryrefslogtreecommitdiffstats
path: root/web/html/pkgsubmit.php
diff options
context:
space:
mode:
authorLoui Chang <louipc.ist@gmail.com>2009-01-08 17:47:49 +0100
committerLoui Chang <louipc.ist@gmail.com>2009-01-08 17:47:49 +0100
commit92643bb8278f3f17d55e1e6c37210ddacb957dae (patch)
tree868660147cb647bbb49118e6c895b4c70d5a5fba /web/html/pkgsubmit.php
parent6e1de70596991374f2e3976e7f5b724f188079ef (diff)
downloadaur-92643bb8278f3f17d55e1e6c37210ddacb957dae.tar.gz
aur-92643bb8278f3f17d55e1e6c37210ddacb957dae.tar.xz
Don't require source or md5sum arrays in PKGBUILDs.
Also fix a translation string. Signed-off-by: Loui Chang <louipc.ist@gmail.com>
Diffstat (limited to 'web/html/pkgsubmit.php')
-rw-r--r--web/html/pkgsubmit.php5
1 files changed, 3 insertions, 2 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index df25360a..b4b94d23 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -155,10 +155,11 @@ if ($_COOKIE["AURSID"]):
$error = __("Missing build function in PKGBUILD.");
}
- $req_vars = array("md5sums", "source", "url", "pkgdesc", "license", "pkgrel", "pkgver", "arch", "pkgname");
+ $req_vars = array("url", "pkgdesc", "license", "pkgrel", "pkgver", "arch", "pkgname");
foreach ($req_vars as $var) {
if (!array_key_exists($var, $pkgbuild)) {
- $error = __("Missing " . $var . " variable in PKGBUILD.");
+ $error = __('Missing %s variable in PKGBUILD.', $var);
+ break;
}
}
}