summaryrefslogtreecommitdiffstats
path: root/web/html/pkgsubmit.php
diff options
context:
space:
mode:
authorAndrea Scarpino <andrea@archlinux.org>2010-06-24 00:19:21 +0200
committerLoui Chang <louipc.ist@gmail.com>2010-06-24 01:17:23 +0200
commitf08fbbe80eba009c6f42411456479e328c92175b (patch)
treec00d0a50305d7288e4a01130003befcd4029d492 /web/html/pkgsubmit.php
parent7e3c624a698406fc34edf75e0914ca3723d345cc (diff)
downloadaur-f08fbbe80eba009c6f42411456479e328c92175b.tar.gz
aur-f08fbbe80eba009c6f42411456479e328c92175b.tar.xz
pkgsubmit: Remove build function check
Closes: http://bugs.archlinux.org/task/19914 Signed-off-by: Loui Chang <louipc.ist@gmail.com>
Diffstat (limited to 'web/html/pkgsubmit.php')
-rw-r--r--web/html/pkgsubmit.php16
1 files changed, 1 insertions, 15 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 0b9335b3..6f7a6697 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -112,10 +112,7 @@ if ($_COOKIE["AURSID"]):
fclose($fp);
# Now process the lines and put any var=val lines into the
- # 'pkgbuild' array. Also check to make sure it has the build()
- # function.
- #
- $seen_build_function = 0;
+ # 'pkgbuild' array.
while (list($k, $line) = each($lines)) {
# Neutralize parameter substitution
$line = preg_replace('/\${(\w+)#(\w*)}?/', '$1$2', $line);
@@ -147,22 +144,11 @@ if ($_COOKIE["AURSID"]):
$lparts[1]);
}
}
- else {
- # Non variable assignment line. (comment, blank, command, etc)
- if (preg_match('/\s*build\s*\(\)/', $line)) {
- $seen_build_function = 1;
- }
- }
}
# some error checking on PKGBUILD contents - just make sure each
# variable has a value. This does not do any validity checking
# on the values, or attempts to fix line continuation/wrapping.
- #
- if (!$seen_build_function) {
- $error = __("Missing build function in PKGBUILD.");
- }
-
$req_vars = array("url", "pkgdesc", "license", "pkgrel", "pkgver", "arch", "pkgname");
foreach ($req_vars as $var) {
if (!array_key_exists($var, $pkgbuild)) {