summaryrefslogtreecommitdiffstats
path: root/web/lib/Archive/PEAR5.php
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-06-06 10:34:28 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-12-27 12:42:12 +0100
commit74edb6fea9d7e8434d8df00a8eb9dc9703daa19d (patch)
tree5f87103b83b51c4702d2d3aa2afba32f627eea3b /web/lib/Archive/PEAR5.php
parent943b6bc9769a03e967f08d8b46bd975e2e8d2a20 (diff)
downloadaur-74edb6fea9d7e8434d8df00a8eb9dc9703daa19d.tar.gz
aur-74edb6fea9d7e8434d8df00a8eb9dc9703daa19d.tar.xz
Use Git repositories to store packages
* Remove package submission page from the web interface. * Replace PKGBUILD and tarball links with links to cgit. * Remove the "URLPath" field from RPC replies. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/lib/Archive/PEAR5.php')
-rw-r--r--web/lib/Archive/PEAR5.php33
1 files changed, 0 insertions, 33 deletions
diff --git a/web/lib/Archive/PEAR5.php b/web/lib/Archive/PEAR5.php
deleted file mode 100644
index 5cee0903..00000000
--- a/web/lib/Archive/PEAR5.php
+++ /dev/null
@@ -1,33 +0,0 @@
-<?php
-/**
- * This is only meant for PHP 5 to get rid of certain strict warning
- * that doesn't get hidden since it's in the shutdown function
- */
-class PEAR5
-{
- /**
- * If you have a class that's mostly/entirely static, and you need static
- * properties, you can use this method to simulate them. Eg. in your method(s)
- * do this: $myVar = &PEAR5::getStaticProperty('myclass', 'myVar');
- * You MUST use a reference, or they will not persist!
- *
- * @access public
- * @param string $class The calling classname, to prevent clashes
- * @param string $var The variable to retrieve.
- * @return mixed A reference to the variable. If not set it will be
- * auto initialised to NULL.
- */
- static function &getStaticProperty($class, $var)
- {
- static $properties;
- if (!isset($properties[$class])) {
- $properties[$class] = array();
- }
-
- if (!array_key_exists($var, $properties[$class])) {
- $properties[$class][$var] = null;
- }
-
- return $properties[$class][$var];
- }
-}