summaryrefslogtreecommitdiffstats
path: root/web/template
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2010-10-06 04:25:53 +0200
committerLoui Chang <louipc.ist@gmail.com>2010-11-10 20:50:35 +0100
commiteda713032ce9bed773b6c927b2f6ac4b445fe577 (patch)
tree8091bc77f982d2d71a50dcd7b1facdd50a3f14c3 /web/template
parentdbb8bb783f2f22b68ad2d65f020390428e77c479 (diff)
downloadaur-eda713032ce9bed773b6c927b2f6ac4b445fe577.tar.gz
aur-eda713032ce9bed773b6c927b2f6ac4b445fe577.tar.xz
Add timestamp when a package is flagged out-of-date (FS#20848).
Signed-off-by: Loui Chang <louipc.ist@gmail.com> - resolve conflict and omit i18n changes.
Diffstat (limited to 'web/template')
-rw-r--r--web/template/actions_form.php2
-rw-r--r--web/template/pkg_details.php5
-rw-r--r--web/template/pkg_search_results.php2
3 files changed, 5 insertions, 4 deletions
diff --git a/web/template/actions_form.php b/web/template/actions_form.php
index d1559f57..41d8df9b 100644
--- a/web/template/actions_form.php
+++ b/web/template/actions_form.php
@@ -27,7 +27,7 @@
echo " value='".__("UnNotify")."' title='".__("No New Comment Notification")."'> ";
}
-if ($row["OutOfDate"] == 0) {
+if ($row["OutOfDateTS"] === NULL) {
echo "<input type='submit' class='button' name='do_Flag'";
echo " value='".__("Flag Out-of-date")."'>\n";
} else {
diff --git a/web/template/pkg_details.php b/web/template/pkg_details.php
index 30d17e17..a4b8f954 100644
--- a/web/template/pkg_details.php
+++ b/web/template/pkg_details.php
@@ -35,6 +35,7 @@ $license = empty($row['License']) ? $msg : $row['License'];
# Print the timestamps for last updates
$updated_time = ($row["ModifiedTS"] == 0) ? $msg : gmdate("r", intval($row["ModifiedTS"]));
$submitted_time = ($row["SubmittedTS"] == 0) ? $msg : gmdate("r", intval($row["SubmittedTS"]));
+$out_of_date_time = ($row["OutOfDateTS"] == 0) ? $msg : gmdate("r", intval($row["OutOfDateTS"]));
?>
<div class="pgbox">
@@ -69,8 +70,8 @@ $submitted_time = ($row["SubmittedTS"] == 0) ? $msg : gmdate("r", intval($row["S
print "<a href='$urlpath.tar.gz'>".__("Tarball")."</a> :: <a href='$urlpath'>".__("Files")."</a> :: <a href='$urlpath/PKGBUILD'>PKGBUILD</a></span>";
}
- if ($row["OutOfDate"] == 1) {
- echo "<br /><span class='f6'>".__("This package has been flagged out of date.")."</span>";
+ if ($row["OutOfDateTS"] !== NULL) {
+ echo "<br /><span class='f6'>".__("This package has been flagged out of date.")." (${out_of_date_time})</span>";
}
?>
</p>
diff --git a/web/template/pkg_search_results.php b/web/template/pkg_search_results.php
index ab49c6b9..bf00da5a 100644
--- a/web/template/pkg_search_results.php
+++ b/web/template/pkg_search_results.php
@@ -46,7 +46,7 @@
$atype = account_from_sid($_COOKIE['AURSID']);
for ($i = 0; $row = mysql_fetch_assoc($result); $i++) {
(($i % 2) == 0) ? $c = "data1" : $c = "data2";
- if ($row["OutOfDate"]): $c = "outofdate"; endif;
+ if ($row["OutOfDateTS"] !== NULL): $c = "outofdate"; endif;
?>
<tr>
<?php if ($SID): ?>