summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitlab-ci.yml3
1 files changed, 3 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 71c14457..6db573d2 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -18,5 +18,8 @@ before_script:
test:
script:
+ - python setup.py install
+ - sed -r "s;YOUR_AUR_ROOT;$(pwd);g" conf/config.dev > conf/config
+ - AUR_CONFIG=conf/config python -m aurweb.initdb
- make -C test
- coverage report --include='aurweb/*'