summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/test/Makefile b/test/Makefile
index 758befa3..060e57c2 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -2,11 +2,19 @@ T = $(sort $(wildcard *.t))
PROVE := $(shell command -v prove 2> /dev/null)
+MAKEFLAGS = -j1
+
+# IMPORTANT: `sh` should come somewhere AFTER `pytest`.
+check: sh pytest
+
+pytest:
+ cd .. && AUR_CONFIG=conf/config coverage run --append /usr/bin/pytest test
+
ifdef PROVE
-check:
+sh:
prove .
else
-check: $(T)
+sh: $(T)
endif
clean: