summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-05-21 15:04:50 +0200
committerGitHub <noreply@github.com>2018-05-21 15:04:50 +0200
commitb6f1553569efeaa0682ff9247c7fc0e93552609d (patch)
treeffc6b33c5effd1daf881fbc24bb756e66785d579 /Makefile.PL
parentfb8fb9b2c69e4d20c5a39a0595e65af8bdcc3161 (diff)
downloadbugzilla-b6f1553569efeaa0682ff9247c7fc0e93552609d.tar.gz
bugzilla-b6f1553569efeaa0682ff9247c7fc0e93552609d.tar.xz
no bug - update dependencies
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 96e340b4f..cda7eefa1 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -33,8 +33,11 @@ BEGIN {
# PREREQ_PM
my %requires = (
+ 'Alien::libcmark_gfm' => 0,
'Algorithm::BloomFilter' => '0.02',
'CGI' => '4.31',
+ 'CGI::Compile' => 0,
+ 'CGI::Emulate::PSGI' => 0,
'CPAN::Meta::Prereqs' => '2.132830',
'CPAN::Meta::Requirements' => '2.121',
'Class::XSAccessor' => '1.18',
@@ -47,6 +50,7 @@ my %requires = (
'Digest::SHA' => '5.47',
'Email::MIME' => '1.904',
'Email::Send' => '1.911',
+ 'FFI::Platypus' => 0,
'File::Slurp' => '9999.13',
'File::Slurper' => '0.012',
'Future' => '0.34',
@@ -63,6 +67,7 @@ my %requires = (
'Math::Random::ISAAC' => '1.0.1',
'Module::Metadata' => '1.000033',
'Module::Runtime' => '0.014',
+ 'Mojolicious' => '7.71',
'Moo' => '2.002004',
'MooX::StrictConstructor' => '0.008',
'Mozilla::CA' => '20160104',
@@ -108,6 +113,16 @@ if ( $OSNAME eq 'linux' && -f '/etc/debian_version' ) {
}
my %optional_features = (
+ argon2 => {
+ description => 'Support hashing passwords with Argon2',
+ prereqs => {
+ runtime => {
+ requires => {
+ 'Crypt::Argon2' => '0.004',
+ },
+ },
+ },
+ },
smtp_auth => {
description => 'SMTP Authentication',
prereqs => { runtime => { requires => { 'Authen::SASL' => 0 } } },