summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-09-19 00:19:03 +0200
committerGitHub <noreply@github.com>2018-09-19 00:19:03 +0200
commitb8b2a943056adbb112474df7bdf766970a56b2dc (patch)
treeac62e6bcd7d795066ce66256a6fdf2d1be101514 /Makefile.PL
parent2f3ca2822570ae271ca4603b5d3de119b40d9eb8 (diff)
downloadbugzilla-b8b2a943056adbb112474df7bdf766970a56b2dc.tar.gz
bugzilla-b8b2a943056adbb112474df7bdf766970a56b2dc.tar.xz
Bug 1455495 - Replace apache with Mojolicious
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL20
1 files changed, 5 insertions, 15 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 6d4225e9a..7e3095867 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -69,6 +69,7 @@ my %requires = (
'Module::Metadata' => '1.000033',
'Module::Runtime' => '0.014',
'Mojolicious' => '7.71',
+ 'MojoX::Log::Log4perl::Tiny' => '0.01',
'Moo' => '2.002004',
'MooX::StrictConstructor' => '0.008',
'Mozilla::CA' => '20160104',
@@ -81,10 +82,12 @@ my %requires = (
'Template' => '2.24',
'Text::CSV_XS' => '1.26',
'Throwable' => '0.200013',
- 'Type::Tiny' => '1.000005',
+ 'Sub::Quote' => '2.005000',
+ 'Type::Tiny' => '1.004002',
'URI' => '1.55',
'URI::Escape::XS' => '0.14',
'version' => '0.87',
+ 'EV' => '4.0',
);
my %build_requires = ( 'ExtUtils::MakeMaker' => '7.22', );
@@ -97,7 +100,7 @@ my %test_requires = (
'Perl::Critic::Freenode' => 0,
'Capture::Tiny' => 0,
);
-my %recommends = ( Safe => '2.30' );
+my %recommends = ( Safe => '2.30',);
# Windows requires some additional modules.
if ( $OSNAME eq 'MSWin32' ) {
@@ -285,18 +288,6 @@ my %optional_features = (
}
},
},
- mod_perl => {
- description => 'mod_perl support under Apache',
- prereqs => {
- runtime => {
- requires => {
- 'mod_perl2' => '1.999022',
- 'Apache2::SizeLimit' => '0.96',
- 'Plack::Handler::Apache2' => 0,
- }
- }
- }
- },
inbound_email => {
description => 'Inbound Email',
prereqs => {
@@ -468,7 +459,6 @@ sub is_bmo_feature {
^
(?: pg
| oracle
- | mod_perl
| sqlite
| auth_ldap
| auth_radius