summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-08-02 17:30:45 +0200
committerGitHub <noreply@github.com>2018-08-02 17:30:45 +0200
commitbb148ee463b034117e4e695d61cab44f61388ce9 (patch)
tree1fa0e3528eac0615457085bc69478d95fc13312e /Makefile.PL
parenta31adbd4dffb0d5cc81763163f8a0437bbe45776 (diff)
downloadbugzilla-bb148ee463b034117e4e695d61cab44f61388ce9.tar.gz
bugzilla-bb148ee463b034117e4e695d61cab44f61388ce9.tar.xz
no bug - add dependencies needed for monitoring
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 46228ab56..d9245c36f 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -362,6 +362,22 @@ my %optional_features = (
},
},
},
+ sentry => {
+ description => 'Sentry Support',
+ prereqs => {
+ runtime => {
+ requires => { 'Log::Log4perl::Appender::Raven' => '0.006' },
+ },
+ },
+ },
+ datadog => {
+ description => 'Data Dog support',
+ prereqs => {
+ runtime => {
+ requires => { 'DataDog::DogStatsd' => '0.05' },
+ },
+ },
+ },
);
for my $file ( glob 'extensions/*/Config.pm' ) {