summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-09-13 22:37:55 +0200
committerGitHub <noreply@github.com>2018-09-13 22:37:55 +0200
commitd3e00529333fb2eadac9c22a45f20c1050401952 (patch)
tree85634ffdbd491ea1fe7fcbcc68ad416f8904caf1 /Makefile.PL
parent5ab05f16aaa44042666c69065dc1c7576eb0de51 (diff)
downloadbugzilla-d3e00529333fb2eadac9c22a45f20c1050401952.tar.gz
bugzilla-d3e00529333fb2eadac9c22a45f20c1050401952.tar.xz
Bug 1490708 - Ensure we always call DBIx::Connector->dbh before any DBI method (#744)
The code didn't allow a way of doing this without a lot of work. So I had to take the following approach: The 'dbh' attribute is now a method that delegates to DBIx::Connector's dbh method. Per the docs, ->dbh() "Returns the connection's database handle. It will use a an existing handle if there is one, if the process has not been forked or a new thread spawned, and if the database is pingable. Otherwise, it will instantiate, cache, and return a new handle." Then there is the matter of the 'handles' on dbh. I've used Package::Stash to insert proxy methods into the class when it is loaded.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3c600bef6..6d4225e9a 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -72,6 +72,7 @@ my %requires = (
'Moo' => '2.002004',
'MooX::StrictConstructor' => '0.008',
'Mozilla::CA' => '20160104',
+ 'Package::Stash' => '0.37',
'Parse::CPAN::Meta' => '1.44',
'Role::Tiny' => '2.000003',
'Scope::Guard' => '0.21',