summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-08-04 18:27:51 +0200
committerDylan William Hardison <dylan@hardison.net>2018-08-04 18:27:51 +0200
commitfc4c941f8c4b8f5ef6036f555703050899e241c2 (patch)
tree595df48facd20c4f0f2104e44fed95bdb8463cff /Makefile.PL
parentf44392e8cdbea85ac308b2472f813ee605ebae4b (diff)
parent43837b61eaf9bc76adadbf8b515522bdb757c67b (diff)
downloadbugzilla-fc4c941f8c4b8f5ef6036f555703050899e241c2.tar.gz
bugzilla-fc4c941f8c4b8f5ef6036f555703050899e241c2.tar.xz
Merge branch 'mojo-poc'
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 9452438ee..b0f7e88ce 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -351,6 +351,22 @@ my %optional_features = (
},
},
},
+ sentry => {
+ description => 'Sentry Support',
+ prereqs => {
+ runtime => {
+ requires => { 'Log::Log4perl::Appender::Raven' => '0.006' },
+ },
+ },
+ },
+ datadog => {
+ description => 'Data Dog support',
+ prereqs => {
+ runtime => {
+ requires => { 'DataDog::DogStatsd' => '0.05' },
+ },
+ },
+ },
);
for my $file ( glob 'extensions/*/Config.pm' ) {