summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-03-13 21:40:31 +0100
committerGitHub <noreply@github.com>2018-03-13 21:40:31 +0100
commit00a44e83c9b1c37b94e2504a06c981535bb51623 (patch)
tree857b3f8eaa36a392e6e3f9132bb249c26502b05a /Makefile.PL
parent6738d7497baeef5c21d4cfa0686bab10b1194815 (diff)
downloadbugzilla-00a44e83c9b1c37b94e2504a06c981535bb51623.tar.gz
bugzilla-00a44e83c9b1c37b94e2504a06c981535bb51623.tar.xz
Bug 1441181 - Step 9 - use pdeathsig to prevent workers running without supervision
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL15
1 files changed, 10 insertions, 5 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 34e4e2487..d7c359bf0 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -22,6 +22,7 @@ BEGIN {
use ExtUtils::MakeMaker 7.22;
use File::Basename;
use File::Spec;
+use English qw(-no_match_vars $OSNAME);
BEGIN {
if ( $ENV{BZ_SILENT_MAKEFILE} ) {
@@ -88,21 +89,25 @@ my %test_requires = (
my %recommends = ( Safe => '2.30' );
# Windows requires some additional modules.
-if ( $^O eq 'MSWin32' ) {
+if ( $OSNAME eq 'MSWin32' ) {
$requires{'Win32'} = '0.35';
$requires{'Win32::API'} = '0.55';
$requires{'DateTime::TimeZone::Local::Win32'} = '1.64';
}
-# for some reason, we need these on ubuntu.
-if ( $^O eq 'linux' && -f '/etc/debian_version' ) {
- my @extra = qw(
+if ( $OSNAME eq 'linux' ) {
+ # This isn't strictly needed, but it is nice to have.
+ # we use it to make sure jobqueue-workers exit when their parent exits.
+ my @extra = qw(Linux::Pdeathsig);
+
+ # for some reason, we need these on ubuntu.
+ push @extra, qw(
Linux::Pid
Test::Pod::Coverage
Pod::Coverage::TrustPod
Test::CPAN::Meta
Test::Pod
- );
+ ) if -f '/etc/debian_version';
$requires{$_} = 0 for @extra;
}