summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2016-11-20 00:12:39 +0100
committerDylan William Hardison <dylan@hardison.net>2017-01-04 23:30:47 +0100
commit419f3ae9fd57fc4e03146a830f7ed780ace83937 (patch)
treef368b61dab21eb036e4b91e1ec947a4b9eeabae9 /Makefile.PL
parent840bbad83e4672fc84083437e384f0d332020f53 (diff)
downloadbugzilla-419f3ae9fd57fc4e03146a830f7ed780ace83937.tar.gz
bugzilla-419f3ae9fd57fc4e03146a830f7ed780ace83937.tar.xz
Bug 1307478 - Elasticsearch Indexer / Bulk Indexer
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 704a896b2..17ed79583 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -313,6 +313,21 @@ my %optional_features = (
}
}
},
+ elasticsearch => {
+ description => 'Elasticsearch-powered searches',
+ prereqs => {
+ runtime => {
+ recommends => {
+ 'Term::ProgressBar' => 0,
+ },
+ requires => {
+ 'Search::Elasticsearch' => 0,
+ 'IO::Async' => 0,
+ 'Role::Tiny' => 0,
+ },
+ }
+ },
+ },
);
for my $file ( glob("extensions/*/Config.pm") ) {