summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2017-09-27 15:06:11 +0200
committerGitHub <noreply@github.com>2017-09-27 15:06:11 +0200
commit4497b6cad46cb53f96290ccd62c9dd23742077ef (patch)
treef733a10954c71a7b46c4afbfef1ce5c079697ec8 /Makefile.PL
parent5e24596e1c7170884f8117a56940e839b0223a2d (diff)
downloadbugzilla-4497b6cad46cb53f96290ccd62c9dd23742077ef.tar.gz
bugzilla-4497b6cad46cb53f96290ccd62c9dd23742077ef.tar.xz
no bug - add dependencies for mozreview/ubuntu
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 33319ce92..fc42b32da 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -84,6 +84,18 @@ if ( $^O eq 'MSWin32' ) {
$requires{'DateTime::TimeZone::Local::Win32'} = '1.64';
}
+# for some reason, we need these on ubuntu.
+if ($^O eq 'linux' && -f '/etc/debian_version') {
+ my @extra = qw(
+ Linux::Pid
+ Test::Pod::Coverage
+ Pod::Coverage::TrustPod
+ Test::CPAN::Meta
+ Test::Pod
+ );
+ $requires{$_} = 0 for @extra;
+}
+
my %optional_features = (
smtp_auth => {
prereqs => { runtime => { requires => { 'Authen::SASL' => 0 } } },