summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-03-04 02:23:42 +0100
committerDylan William Hardison <dylan@hardison.net>2018-03-10 21:54:38 +0100
commit78ebe18f428f152558fd2912c757f6b4448900a8 (patch)
treedea35276679af0aa8eaf7a7e58e9380ec367eafd /Makefile.PL
parentd6bc2a79456a319fe073a470d1643721bf7adf5e (diff)
downloadbugzilla-78ebe18f428f152558fd2912c757f6b4448900a8.tar.gz
bugzilla-78ebe18f428f152558fd2912c757f6b4448900a8.tar.xz
psgi optionalize until can rebuild vendor bundle
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 97caea271..57bc06001 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -325,6 +325,32 @@ my %optional_features = (
}
}
},
+<<<<<<< HEAD
+=======
+ psgi => {
+ description => "PSGI Support",
+ prereqs => {
+ runtime => {
+ requires => {
+ 'Plack' => '1.0031',
+ 'CGI::Compile' => 0,
+ 'CGI::Emulate::PSGI' => 0,
+ },
+ },
+ },
+ },
+ csp => {
+ description => 'Content-Security-Policy support',
+ prereqs => {
+ runtime => {
+ requires => {
+ 'Type::Tiny' => 1,
+ 'MooX::StrictConstructor' => 0.008,
+ }
+ }
+ }
+ },
+>>>>>>> 741eeec31... psgi optionalize until can rebuild vendor bundle
elasticsearch => {
description => 'Elasticsearch-powered searches',
prereqs => {
@@ -370,6 +396,7 @@ my @bmo_features = grep {
(?: pg
| oracle
| mod_perl
+ | psgi
| sqlite
| auth_ldap
| auth_radius