summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2018-03-18 17:17:12 +0100
committerDylan William Hardison <dylan@hardison.net>2018-03-18 17:17:23 +0100
commita1f221ad7bdb20ce0f498e52c1556a4cfbbdeb87 (patch)
treeae2a1b1102e15b6e6a6e501251c3ab33b9e9c6db /Makefile.PL
parent2b7259f28e783ee8fe410217ee41c4809aba75b7 (diff)
downloadbugzilla-a1f221ad7bdb20ce0f498e52c1556a4cfbbdeb87.tar.gz
bugzilla-a1f221ad7bdb20ce0f498e52c1556a4cfbbdeb87.tar.xz
fixup Makefile.PL
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL77
1 files changed, 31 insertions, 46 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 57bc06001..8e20d52b9 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -22,6 +22,7 @@ BEGIN {
use ExtUtils::MakeMaker 7.22;
use File::Basename;
use File::Spec;
+use English qw(-no_match_vars $OSNAME);
BEGIN {
if ( $ENV{BZ_SILENT_MAKEFILE} ) {
@@ -53,14 +54,11 @@ my %requires = (
'HTML::Escape' => '1.10',
'IO::Async' => '0.71',
'JSON::MaybeXS' => '1.003008',
- 'JSON::MaybeXS' => '1.003008',
'JSON::XS' => '2.01',
'LWP::Protocol::https' => '6.07',
'LWP::UserAgent' => '6.26',
'List::MoreUtils' => '0.418',
'Log::Dispatch' => '2.67',
- 'Log::Dispatch' => '2.67',
- 'Log::Log4perl' => '1.49',
'Log::Log4perl' => '1.49',
'Math::Random::ISAAC' => '1.0.1',
'Module::Metadata' => '1.000033',
@@ -69,10 +67,8 @@ my %requires = (
'MooX::StrictConstructor' => '0.008',
'Mozilla::CA' => '20160104',
'Parse::CPAN::Meta' => '1.44',
- 'Plack' => '1.0031',
'Role::Tiny' => '2.000003',
'Sereal' => '4.004',
- 'Sereal' => '4.004',
'Taint::Util' => '0.08',
'Template' => '2.24',
'Text::CSV_XS' => '1.26',
@@ -95,16 +91,14 @@ my %test_requires = (
my %recommends = ( Safe => '2.30' );
# Windows requires some additional modules.
-if ( $^O eq 'MSWin32' ) {
+if ( $OSNAME eq 'MSWin32' ) {
$requires{'Win32'} = '0.35';
$requires{'Win32::API'} = '0.55';
$requires{'DateTime::TimeZone::Local::Win32'} = '1.64';
}
-# for some reason, we need these on ubuntu.
-if ( $^O eq 'linux' && -f '/etc/debian_version' ) {
+if ( $OSNAME eq 'linux' && -f '/etc/debian_version' ) {
my @extra = qw(
- Linux::Pid
Test::Pod::Coverage
Pod::Coverage::TrustPod
Test::CPAN::Meta
@@ -317,40 +311,30 @@ my %optional_features = (
},
},
},
- jobqueue => {
- description => 'Mail Queueing',
- prereqs => {
+ linux_smaps => {
+ description => 'Linux::Smaps for limiting memory usage',
+ prereqs => {
runtime => {
- requires => { TheSchwartz => '1.10', 'Daemon::Generic' => 0 }
+ requires => { 'Linux::Smaps' => '0' },
}
- }
+ },
},
-<<<<<<< HEAD
-=======
- psgi => {
- description => "PSGI Support",
+ linux_pdeath => {
+ description => 'Linux::Pdeathsig for a good parent/child relationships',
prereqs => {
runtime => {
- requires => {
- 'Plack' => '1.0031',
- 'CGI::Compile' => 0,
- 'CGI::Emulate::PSGI' => 0,
- },
+ requires => { 'Linux::Pdeathsig' => 0 },
},
},
},
- csp => {
- description => 'Content-Security-Policy support',
+ jobqueue => {
+ description => 'Mail Queueing',
prereqs => {
runtime => {
- requires => {
- 'Type::Tiny' => 1,
- 'MooX::StrictConstructor' => 0.008,
- }
+ requires => { TheSchwartz => '1.10', 'Daemon::Generic' => 0 }
}
}
},
->>>>>>> 741eeec31... psgi optionalize until can rebuild vendor bundle
elasticsearch => {
description => 'Elasticsearch-powered searches',
prereqs => {
@@ -390,22 +374,7 @@ for my $file ( glob 'extensions/*/Config.pm' ) {
}
# BMO Customization
-my @bmo_features = grep {
- !m{
- ^
- (?: pg
- | oracle
- | mod_perl
- | psgi
- | sqlite
- | auth_ldap
- | auth_radius
- | smtp_auth
- | linux_pid
- | updates)
- $
- }mxs;
-} keys %optional_features;
+my @bmo_features = grep { is_bmo_feature($_) } keys %optional_features;
$optional_features{bmo} = {
description => 'features that bmo needs',
@@ -456,3 +425,19 @@ META.yml: Makefile.PL
MAKE
}
+sub is_bmo_feature {
+ local $_ = shift;
+ return 1 if $OSNAME eq 'linux' && /^linux/;
+ return !m{
+ ^
+ (?: pg
+ | oracle
+ | mod_perl
+ | sqlite
+ | auth_ldap
+ | auth_radius
+ | smtp_auth
+ | updates)
+ $
+ }mxs;
+}