summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2016-10-15 00:13:29 +0200
committerDylan William Hardison <dylan@hardison.net>2016-10-15 00:13:29 +0200
commit2f310fba9800f9d106ad8090cbbfb628c53599a1 (patch)
treed51f1f2ac639176bd8a1ece83f5a0cea49034115 /Makefile.PL
parent0bd2c876589e8a86a086460f05fdca72f34b1609 (diff)
downloadbugzilla-2fe7bbb1ddd5d33767212f516d3d7dd7cb9a6998.tar.gz
bugzilla-2fe7bbb1ddd5d33767212f516d3d7dd7cb9a6998.tar.xz
Bug 1308949 - Keep MYMETA.json up-to-date when checksetup is runmozreview
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index a84aa1cdf..1bee517c8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -22,6 +22,13 @@ use constant BUGZILLA_VERSION => $ENV{BUGZILLA_VERSION} // 42;
use File::Basename;
use File::Spec;
+BEGIN {
+ if ($ENV{BZ_SILENT_MAKEFILE}) {
+ open STDOUT, '>>', File::Spec->devnull;
+ open STDERR, '>>', File::Spec->devnull;
+ }
+}
+
# META.json and META.yml exist only for the benefit of older
# installs where cpanm can't get the optional features out of Makefile.PL
# Unfortunately having META.json and META.yml commited to the repo is weird