summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan William Hardison <dylan@hardison.net>2016-07-04 16:43:48 +0200
committerDylan William Hardison <dylan@hardison.net>2016-09-10 18:40:58 +0200
commit1e2027a97adb7481c7cb296330039313fefd95c6 (patch)
treef8f900af1e38e4020c8580c58cd3e2faa54a6569 /Makefile.PL
parentc61b7ce75f229d4034099e8e93c56d98208bc799 (diff)
downloadbugzilla-1e2027a97adb7481c7cb296330039313fefd95c6.tar.gz
bugzilla-1e2027a97adb7481c7cb296330039313fefd95c6.tar.xz
Bug 1284263 - Add optional support for $DATABASE_URL instead of localconfig for db_* connection params.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 36559b63c..3af1d58e5 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -298,6 +298,14 @@ my %optional_features = (
}
}
},
+ db_from_env => {
+ description => 'Support for using $ENV{DATABASE_URL}',
+ prereqs => {
+ runtime => {
+ requires => { 'URI::db' => '0.17' },
+ },
+ },
+ },
);
for my $file ( glob("extensions/*/Config.pm") ) {