summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorDylan Hardison <dylan@mozilla.com>2016-07-28 19:49:14 +0200
committerDylan Hardison <dylan@mozilla.com>2016-07-28 19:51:50 +0200
commit742fab1ca9c0e66f46fbaf08af26c31b5e5fd9a3 (patch)
treee5b13a93186cdc515c56898fc365f139e01922d4 /Makefile.PL
parent66a6a5cba35dabe7b7d60c6a59b929e2a54548a2 (diff)
downloadbugzilla-742fab1ca9c0e66f46fbaf08af26c31b5e5fd9a3.tar.gz
bugzilla-742fab1ca9c0e66f46fbaf08af26c31b5e5fd9a3.tar.xz
Bug 1286287 - Add utility method to Bugzilla::CGI for configuring CSP headers
r=dkl,a=dylan
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index eaa232222..101bdf32b 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -296,6 +296,18 @@ my %optional_features = (
}
}
},
+ csp => {
+ description => 'Content-Security-Policy support',
+ prereqs => {
+ runtime => {
+ requires => {
+ Moo => 2,
+ 'Type::Tiny' => 1,
+ 'MooX::StrictConstructor' => 0.008,
+ }
+ }
+ }
+ },
);
for my $file ( glob("extensions/*/Config.pm") ) {