summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorFrédéric Buclin <LpSolit@gmail.com>2016-03-25 22:30:54 +0100
committerFrédéric Buclin <LpSolit@gmail.com>2016-03-25 22:30:54 +0100
commitab88cc202fcfd78088338c378d2f02515838331e (patch)
tree6b4c819d53f93c1b9d67da78c0612fb9c0130d3c /Makefile.PL
parent3368986490028be41351d4329fb4976df2eb75e1 (diff)
downloadbugzilla-ab88cc202fcfd78088338c378d2f02515838331e.tar.gz
bugzilla-ab88cc202fcfd78088338c378d2f02515838331e.tar.xz
Bug 1257224: Windows-specific modules are missing in Makefile.PL
r=dylan
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3880acaff..062a94754 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -61,6 +61,13 @@ my %requires = (
'URI' => '1.55',
);
+# Windows requires some additional modules.
+if ($^O eq 'MSWin32') {
+ $requires{'Win32'} = '0.35';
+ $requires{'Win32::API'} = '0.55';
+ $requires{'DateTime::TimeZone::Local::Win32'} = '1.64';
+}
+
my %optional_features = (
features => {
prereqs => { runtime => { requires => { 'CPAN::Meta::Check' => 0, 'Module::Runtime' => 0, 'CPAN::Meta' => 0, }, }, },